Oopsy Update Prerelease! Want to Try the New Features Early?

Hey Sascha!

Could you tell me more about the “fix for the Petal preset in range”? I could ask if that’s going to be included in the new release.

As for the Daisy bootloader, it’s actually just adding one line to your JSON file.
I made a step-by-step guide here. Please let me know if you have any questions!

Hi Takumi,
Possibly reporting a small bug. I have my JSON file saved within the “/include” folder as Im using it with C++ inserts. When Flashing from MAX in Bootloader mode the flash fails and shows your second version of the bpatcher windows which reads:
generated code
dfu Error
created binary 102kb

The LED does not continue to flash/pulse and stays in “ready” mode.

You mentioned the JSON file (with “app_type”: “BOOT_SRAM”,) had to live in the root of the oopsy package but ive been asked to place it in the /include folder so the C++ inserts work.

Please advise.

Also, How does one exit “Bootloader Image” mode?

Hey AD!

Thank you for trying out the new prerelease :slight_smile:

I’ll answer the latter question first. After you flash the Bootloader Image, you can keep using the Daisy bootloader without needing to flash Bootloader Image every time. UNLESS, you go into DFU in FS Mode (by doing the usual button presses on Daisy) and, let’s say, flash a blink example into the internal flash. That’ll be the “exit”. If you want to use the Daisy Bootloader again, you have to flash the Bootloader Image.

As for the first question, I just want to double check if you were able to get those two features (Daisy bootloader and C++ inserts) working individually/separately? And it sounds like it becomes an issue to you when you try to do it simultaneously.
Could you share that JSON file? As well as the error messages. Thanks!

Thank you Takumi,
That reset to normal operation worked, thank you. I was able to get the C++ inserts working correctly when not in Bootloader Image mode. I’ll do some more tests and get back to you with error messages.

Hi again,

is there a new version in sight with a fix for the Petal template not compiling ?

Hi Sascha!

I’m sorry for the delay in updating you about it.
It was added to GitHub issue recently. Thank you for bringing it up!

hmmm…are you sure ?
I just cloned that and i still get the same compiler error as before.
No need for access to the hardware to test…just make a new file from Template , choose Petal, uncheck Quiet and press Compile.
Versio also is broken still…

I think when @Takumi_Ogata said:

It was added to GitHub issue recently.

He meant that the ‘issue’ was added to the list on github, not that it was fixed in the github source.

I should have used the correct terminology of “open” there. I’m sorry about that. The issue was opened on GitHub but you will have to wait until it is fixed. Thank you for the wait!

Ah, ok :slight_smile:
I misunderstood…my bad…
Is there an easy way for me to track the update status automatically ?

I haven’t used it before but clicking the subscribe button on the issue page might send you an email when there’s an update.


Glad there’s a new Oopsy update.
I’m particularly interested by " C++ Inserts" to display custom output param.

I looked at GitHub code to understand how it works but with no success.
Is there any sample code to understand how it works?


Hi Felart!

Yes, we’ll definitely want to distribute an example of C++ inserts in the near future. Thank you for bringing it up!
We’ll make announcements regarding the new Oopsy release and examples for it. We would greatly appreciate your waiting!

Hmm - I’m still having trouble getting negative CV values with this update. Is there anything else I have to change in my JSON to get negative CV? Ive changed the cv param to @min -1 instead of @min 0.

As far as I can tell, that issue was addressed but has not yet been merged with this bootloader-additions branch nor the main branch just yet.

If you’re using the current version of Oopsy, you can do the following in the JSON file to get the negative CV:

  "inputs": {
    "cv5": {
      "range": [-1, 1],
      "code": "hardware.GetAdcValue(daisy::patch_sm::CV_5);"

Thanks so much for your response! I guess I’m using the Oopsy I just installed from this page along with my custom JSON code for my homebuilt patchsm, but it still doesnt seem to take bipolar. My code is:

	"components": {
	"cv_1": {
		"component": "AnalogControl",
		"pin": "C1",
        "is_default": true,
		"range": [-1, 1],
		"code": "hardware.GetAdcValue(daisy::patch_sm::CV_1);"

But still nothing. In Max I’m using “param cv2 @min -1 @max 1”
Am I doing something wrong here?

If you’re using the version of Oopsy cloned from the bootloader-additions branch, then the JSON file style will be different. And I’m not entirely sure how the range will work differently.
I recommend installing the current version (not the pre-release discussed here) and give that
"range": [-1, 1] a try.

Or use the current style of JSON file in the pre-release and see if that helps.

OH, and you’re using [param cv2] even though you changed the range in the JSON for cv_1. That could be it too.

Looks like you need to change the component from “AnalogControl” to “AnalogControlBipolar”!

1 Like

Hi all,

Success ! I finally have red/blue blinking instead of red/green :slight_smile:
Or in detail, i managed to flash the bootloader into the pod and then flash the oopsy_pod template to it.
I then tried to flash on of my gen~ effects that run fine on the old oopsy into the new one and that did not work somehow.
The pod comes back with both LEDs white and no action…no blinking LED on the seed…as if its stalled.
Does the new oopsy require some changes in the way we handle the param IO in gen` ?

Also, as a general thing…do the examples from the web programmer work or do they need to be recompiled for the bootloader ?