DFU in FS Mode option not appearing

I’ve entered boot mode on my Pod and cannot find this option in the dropdown list for connections.
I’m getting several different options such as:
Unknown Device [1002:4399] - paired

Why am I not able to boot into the DFU?

It took me a while to figure this out so here are the steps I used to get mine to work:

  • Make sure you’re connecting to the daisy via the micro-usb port on the daisy seed itself, not the pod connector.
  • Once connected and powered on, hold the boot button and click the reset button (two white buttons on the seed, look closely for the labels printed on the PCB). Once you follow this sequence, click connect and hopefully it should show up in the list.

Good luck!

1 Like

It’s worth also mentioning - Note that not all USB -> Micro USB cables have data connected - some cheap ones only have power. That has caught me out before!

1 Like

Yeah, I’m plugging directly into the seed, go into boot mode and computer detects the device. But no DFU connections available and only “NotFoundError: No device selected.” is given.

I’ve tried numerous cables - good point.

And I’m guessing you’re meeting the browser req as well?

An up-to-date version of Chrome, at least version 61 or newer

Which OS are you using?

If you are on Windows you might need to use Zadig to select a different USB driver.

To begin, download Zadig. Use the most recent version.

Launch Zadig and then put the Daisy into bootloader mode by holding BOOT and pressing RESET.
Click the Options menu in Zadig and select “List All Devices.”

In the drop down menu inside the main window, select “DFU in FS mode,” followed by selecting WinUSB in the target driver box.

Click “Replace Driver.” Zadig will update to the appropriate driver to flash Daisy.
These instructions are also in the Windows Toolchain Install Wiki page on GitHub with screenshots.

edit: To clarify, Zadig is not only for command line programming but can be used for the Web Progammer as well on Windows. It should fix the connectivity problem if the USB driver is to blame.

I’m also having this issue : https://www.youtube.com/watch?v=KW8xsNnbOuA

I’m on Chrome83 , MacBookPro mid-2012 running 10.11.6 (el cap)

would love your help! Thanks!

(I’ve tried two microUSB cables so far)

Chiming in as I’m also having this issue – in my case, Win10, Chrome83. I’ve cross-checked with multiple (confirmed working) microusb cables, and all I can see in the chrome usb devices window are a few “unknown devices”.

I do get a “STM device in DFU mode” in my Device Manager – so I’ll try the Zadig method @andrewikenberry mentioned. I’m sad I can’t use the nice web programmer!

Worth mentioning, Zadig is not only for command line programming.
It will also fix your Web Programmer connectivity issue if the USB driver is the culprit.

I’ll make an edit on my og post to clarify.

@Button did the USER LED on the Seed stop blinking once you entered bootloader mode? If not, then the button combo was not performed correctly.

oh, awesome! that fix worked perfectly for me – thanks Andrew!

1 Like

@andrewikenberry Thanks so much for your reply.

I see 3 LEDS. A small red one near the MicroUSB port. And two Red/Blue/Green LEDS next to the SW1 and SW2 buttons.

I plug in daisy pod to microUSB.
Both Red/BlueGreen LEDS cycle through those colors once at a time.
I hold RESET button then press BOOT (and vice-versa) then the Red/Blue/Green LEDS stop cycling through their colors.
What’s left is only one illuminated LED : steady RED colored LED (not blinking) next to the microUSB power port.

Thanks!
-B

OK, couple things worth mentioning:

  • For flashing over USB, make sure you plug your micro USB cable into the Daisy Seed itself, and not into the secondary USB port on the Pod.

  • There are two red LEDs on the Daisy Seed, one on each side of the micro USB port. The one that is labeled USER should be flashing periodically when you receive it. The other LED labeled PWR should be illuminated whenever the Daisy Seed is powered.

@andrewikenberry Again, thank you!

To confirm :

  • Daisy Seed USB port is the one located on the “elevated” platform, situated between the two tiny LEDs you mentioned (PWR and USER). Yes?

  • As you might imagine, I did not detect the USER LED (partially because it’s not bright enough in this room, partially because my eyes are going bad, partially because it never illuminated, and partially because I’m not bright enough)

  • I’m not seeing the USER LED light up at all. It’s not blinking. It’s not shining. Nowhere in the course of powering up the Daisy then pressing the boot+reset buttons does the USER LED light shine.

Very grateful to you for ideas on what to try next!
I’ll restart my browser. Maybe that’ll help…

  • B

@Button it sounds like you’re doing everything hardware related correctly.

I can replicate your steps and have the device show up on a similar MacBook, but running Catalina.

If you perform those steps with the Connect dialog open do you see any devices get added to the list? Or removed when disconnecting the Daisy?

I suppose there’s a chance it’s showing up as something different, but I’ve only seen it show up as what’s in the documentation on multiple OSes so far.

I had the same issue and was very confused for a couple hours. I eventually tried connecting to my other laptop (both PCs). This time when I plugged in Daisy, my laptop said it was installing drivers. At this point Daisy “woke up” out of dfu mode and worked on my main computer as well. This is not very scientific but hope it helps.

After trying to detect the Daisy in DFU mode on 2 different PCs and 2 different Macs, I finally got my Macbook to recognize it. I uploaded a program and rebooted…now the single red light on the seed is all that is lit up. When I plug in USB power, the 2 lower lights light extremely briefly and then nothing.
What is happening now?Shouldn’t the blue/green LEDs light up as well?
This thing is becoming more trouble than its worth.

The function of those LEDs will depend on the program that you have flashed to the Daisy.

For example if you flashed the SimpleButton example program, those LEDs will illuminate only when the buttons are pressed.

Yeah, that seems to be what it was. I was expecting all LEDs to flash as before, but the top LED is all that needs to flash for the simple oscillator sketch. Still kind of frustrating that I can only get this to work on one computer though. A firmware fix for better compatibility in the works maybe?

@waredgo on your PCs did you try Zadig for resetting your USB driver?
There are instructions here or further up in this thread.