Daisy patch start


Just got a daisy patch. Put it in my rack and I see 4 bars following 4knobs movements. great.
Now I want to understand how to pug it start experiment with pure data.
I see this page called " Daisy (Get Started Here)" and I get to the step 2 boot led blinking…
from there I have no idea what I need to do and all seems very confusing.
Sure thing is now the 4 bars are gone and if I turn off/on dasy I only get the reset LED fix.
Could you please link me to the steps so I go forward ? again I “just” want to upload pure data patch nothing else.
oh something else the daisy patch does not come with a micro SD ? I have some… it’s just that I hoped the unit would be ready to go with some exemples and things on an SD maybe ?

Hey fgodzillao!

This video tutorial will help you get started with pd2dsy (Pure Data integration for Daisy): How to Add Daisy Support to Pure Data (pd2dsy) - YouTube

It’s also worth noting that the OLED and SD card are not yet supported with pd2dsy.

Yes thanks just watched it !
Went into pure data because of your videos already and now daisy :smiley:
I had the USB issue, reinstaled it and now this one :stuck_out_tongue:

Error: unkown error
If your problem persists,
check the log file at “F:\PRESETS\MODULAR\EURORACK\DAISY\pd2dsyGUI\data\pd2dsy_build.txt”
to check for errors and consider posting
it to the Daisy Forum.

make: *** F:\PRESETS\MODULAR\EURORACK\DAISY\BLINK: No such file or directory. Stop.

so I randomly tried to creat that FOLDER and Flash Program again but now get:

make: *** No rule to make target ‘DAISY’. Stop.

Ah nice! Glad you found the video helpful :slight_smile:

Ok, let’s simplify the directory.
It seems like moving the pd2dsyGUI folder to Users worked for people. Give that a try and see if that issue still pops up.

So I moved pd2dsyGUI folder to Users.
but I get this.

Pd translation error:
path is on mount ‘C:’, start on mount ‘F:’

I tried to do the zadig again or change the pd2dsy_blink to Users but then I get
[WinError 5] Refused access: ‘C:\Users\pd2dsyGUI\pd2dsy_blink\blink\hv’

Alright, let’s take a step back.
Were you able to get the Daisy blinking using the Daisy Web Programmer?
I wanted to confirm that with you.

And I don’t think I have seen [WinError 5] before.
Could you share screenshots of how your directory looks like, what’s displayed on zadig, and also what your pd2dsyGUI looks before flashing? Thanks :slight_smile:


Yes the Daisy Web Programmer worked.
reset boot = no blink,
select the FS… something then patch
and i get blinking and the following:

Erasing DFU device memory
Copying data from browser to DFU device
Wrote 59136 bytes
Manifesting new firmware

1 Like

what your pd2dsyGUI looks before flashing?
looks all black
When I first plubed in the module I had 4 bars following pots positions.

When I turn off / on unit and disconnect USB cable.
led is still blinking

Good to hear that the Web Programmer is working :slight_smile:

Sorry, I meant the whole app. It should look like this:

I just want to make sure it’s all set up.

That’s just the firmware that came flashed onto the patch before it was shipped.

Yep, the blink firmware is flashed (when you did via the Web Programmer) so it’ll stay there even when you restart.

We can try something else.

In your pd2dsy GUI, could you go to FileExamplesPatch example? And see if you can flash that.

Your GUI should look like this before flashing:

Don’t forget to put the Daisy in bootloader mode before flashing. Let me know if it works or not.

thx looks like this worked i got:

Flashing Daisy…
Daisy successfully flashed!

Is this “patch_test.pd” something I can test using the module on it’s own ?
can I open it in pure data to look at it ?

once flashed daisy is not blinking any more.
can I simply unplug theUSB or do I need some special eject procedure ?

Nice!! Glad to hear that you were able to flash successfully.

Yes, it’ll be a great idea to have a look at the patch_test.pd to understand how to use the Daisy Patch with Pure Data.

You can find that patch in:

When you flash something new, the firmware that’s already embedded is replaced. So in this case, the blink program was deleted and the patch_test program was flashed afterwards. It’s not accumulative.

Another key thing to note as you go on your pd2dsy journey is that not all objects are supported by hvcc.
Here’s a list here: Unsupported objects | hvcc

plugdata makes this easy to tell with its Compiled Mode. It lets you know if a certain object is supported or not. It’s super neat :slight_smile:
And you can flash your patch to the Daisy directly in plugdata as well. I recommend checking it out!

Have fun and let me know if you have any questions during your journey!!

So I looked at the patch and I would expect this to happen (?);
a 440Hz tone on outs1-4
turning encorder changes pitch up / down.
knobs control levels ouf outs1-4
and trigs would send a 1/2sec AD to out 1 or 2.

but what I get is a constant pitch (not 440hz) on out 3-4
and nothing on 1-2 no matter gate1-2
encoder does not change pitch

I tried plugdata. I like the interface but the compile comes back wirh errors (?)
I select ;
Currentrly opened patch
target = patch
export type = Flash
ROM optimisation for speed
RAM optimisation for speed

And the export report says :
Download done.
File downloaded successfully
Warning: Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Error during download get_status
make: *** […/…/libdaisy/core/Makefile:330: program-dfu] Error 74

Let’s stick with pd2dsyGUI for now then.

Yep, you got the right idea for that example patch. :slight_smile:

What I would like you to do is go step-by-step:

  • Start a new patch with just [osc~ 440] to [dac~ 1 2 3 4]. Simple as possible.

  • Sounds coming out as expected? Cool! Let’s add the knobs to control amplitude like how it’s done in that example.

  • Add gate next…

And so on and so forth. It’ll be crucial to isolate things for me to troubleshoot with you.

So i used pure with just [osc~ 440] to [dac~ 1 2 3 4]
patch in pure data works fin
flashing using pd2dsyGUI gives
Flashing Daisy…
Daisy successfully flashed!
but the module gives the same result as before.
sound goes only to 3&4 with nasty 1kish sawtooth.

So there’s no sound from output 1 & 2? And did you make sure to put patch as the target?

Ok, let’s see if the hardware itself is working.
Could you flash the example firmware on Daisy Web Programmer ? Something like the Patch VCO should work fine. Let me know if it works.
If there’s audio, then there might be something up with pd2dsyGUI with Patch.

Sorry i’m a bit confused about the second part.
So I take this [osc~ 440] to [dac~ 1 2 3 4] that works fine in pure data
and use this page :Daisy Web Programmer
rather the plugdata or the pd2dsy_gui.exe
But in that interface I’m not sure opf the procedure:
1- start module with boot procedure
2- connect from the Daisy Web Prog page
3- select patch
4- choose file (that pure data small patch)
5- … program ?

if so I got:

Erasing DFU device memory
Copying data from browser to DFU device
Wrote 194 bytes
Manifesting new firmware

But then no sound from any audio output in the module.

wait… I just tried to use technic above but select the “VCO” in “exemple”
and it is working as expected looks like
other patch from exemples are working too. Env oscillator, Polyosc.
so don’t know why my little patch is not working so far :stuck_out_tongue:

I’m glad to hear that the WebProgrammer examples are working! This means that your hardware itself is working as expected.

Let’s get back to pd2dsyGUI then.
I just want to double check two things with you:

  1. Your patch looks like this, correct? Filename can be simple_oscillator.pd for example.

Screenshot 2023-05-25 at 1.21.06 PM

  1. In your pd2dsyGUI, make sure you have Patch selected in Board and of course the correct pure data patch (in this case simple_oscillator.pd chosen in Pd File.

Let me know if there’s any sound coming out or not.

yes exactly that.
1&2 no sound 3&4 sound.
I tried with pd2dsy, the online tool and plugdata
plugdata says:
Error during download get_status
make: *** […/…/libdaisy/core/Makefile:330: program-dfu] Error 74

Sorry just to recap see if I do anything wrong:
1- power on the module through the case.
2- plug daisy via USB to computer
3- press reset / boot, let go reset then let go boot.
4- open pd2dsy (or do I need to do anything else first ?
6- select the PD file(exactly the one from your picture) / Board= Patch /no Json / ROM = speed
7- press Flash program.
result message is:
Flashing Daisy…
Daisy successfully flashed!”
8- plug cable from out 1 to 4 (USB still pluged in)
out1&2 = >10k hiss
out3&4 = 1kish saw tooth.

Is there a procedure before that I should do… i’m lost really.
I just tried to do another patch like [osc~ 600]=[dac~]
result is exactly the same as above…
So the only thing I can load in are the exemples from the web programmer.

unit could have a problem ?

I don’t think it’s anything wrong with the hardware since you were able to get sounds out of it using the Web Programmer. Something funky could be happening with pd2dsy (or pd2dsy GUI).

I will bring this up to the team and look into it further. Could you tell me what OS you’re running?

I’m sorry about the not-so smooth start to your journey.