Daisy patch start

Another thing to maybe try out is test [phasor~ 440] or [noise~]. It’s possible that the output is low with the program built by pd2dsy? You can also crank up the volume with [*~]. Make sure you have [clip~ -1 1] right before [dac~ 1 2 3 4].

thx for support.
using [phasor] [noise] always give same result as above.
I tried to load exemples like polyOSC or Noise… all works fine.
it’s just my exports from PD that don’t work.

I use Windows10.

Thank you for the info.

We’ll investigate this further and keep you posted.

I would verify that the C++ Patch examples can be built from source, and run correctly. Are current versions of libdaisy and daisySP installed?

1 Like

hi tele player.

I don’t understand anything you are saying. Sorry :upside_down_face:
but I guess you’r talking to Tayumi Ogata (?)

Also… just to make sure. People can actually load puredata patch to their daisy patch correct ? It’s only me having problem for some reason ?

Hey Takumi.

I will be on holiday a week then back but away later in june…
I’m a bit concern finding a solution will take longer because i’m still in the time period to return the unit to the shop. The only reason I bought it is to use pure data and if it’s not possible than really, as interesting as it is, the unit is no use for me.
So sorry for the silly question but : are people using it with pure data really ? Or are we so few that it’s a beta version with not much development yet ?

I believe lot of people get the Daisy for using Pure Data and pd2dsy does indeed work. I’m not sure why your Patch is not behaving well with it. I will bring this up to the team and let you know our findings.

It’s worth noting that OLED and SD card don’t work with pd2dsy yet, so you may reconsider since your plan is exclusively using Pure Data. Of course, if you’re fine focusing on synth design while also waiting for those two features to be added, then keeping the Patch is an option.

Either way, we do no need to look further into this.

By the way, I don’t think you actually had the blink example working with pd2dsyGUI? Could you confirm that you have it working? I could’ve missed it while rereading this thread, and I’m sorry if that’s the case.

And to double check, you did install the toolchain, correct? 1c. Installing the Toolchain on Windows · electro-smith/DaisyWiki Wiki · GitHub

Ideally, you get things working on pd2dsyGUI, but it could be worth revisiting plugdata.


Thx for your time.
I resinstalled the toolchain.
Blink works with pd2dsyGUI and with the online daisy web programmer. I get the boot led flashing.
but not with plugdata.

1 Like

Thank you for the confirmation.

The blink example doesn’t work with plugdata just yet. Were you able to flash some synth using plugdata?

so something weird… really not saying it’s related. But I just removed the unit from my case. And once removed I hear a sound like a nut is not tight. I shake it here and there and after a while a screw just drops of ! it’s a screw that is not the one used for eurorack. With a cone head. and I turn the board and see that there’s 4 screws there and the one I just found is one missing :stuck_out_tongue:
I can screw it back and test things again. Not saying that’s the problem but having a screw running inside on the PCB is not ideal I guess.

I’m glad they didn’t cause the Patch to short circuit! Yeah, I’m not sure if it’ll fix it but they weren’t safe to have around in there.

This reminded me…
There was a post a while back where a fellow community member unplugged and plugged in their Patch SM and it worked again. So that classic electronics method could be worth doing just in case.

sorry not sure what you mean ?

Unplugging and then plugging the power cable :slight_smile:

mmm I tried that. for exemple, flash the Patch , then on/off… still the same.
Maybe there’s a specific moment in the routine where it works… i can try but that will be 7 june I have a plane in 6 hours :stuck_out_tongue:

Nothing complex like that, I’m sorry for the confusion. Just simply making sure the power cable is firmly plugged in before powering it back on.

But the main priority is flashing some audio example once those little components are out of the Patch.
I will be right here when you’re back.

Enjoy your holiday!!!

Hi !

Been out for 3 months.
repatching all my cases. Wonder if the daisy patch is now working.
Forgot all about how to update it and everything.
Can anyone give me a link to any update (and how to install) that hopefully fixed my problem ?

Welcome back!

In terms of setting things up, the documents are the same so you can follow as before :slight_smile:
Let me know how things are going.


Using pd2dsy I’m getting this now :

Pd translation error:
[Errno 13] Permission denied: ‘C:\Users\pd2dsyGUI\data\util\daisy.json’

I tried to make sure no file was “read only” it’s the same.
The Daisy Web Programmer works with the blink. led is blinking
all is the same as before. I can load the exemples from the Daisy Web Programmer.
But the simple osc to dac patch I do doesn’t work.
I mean I get :
Erasing DFU device memory
Copying data from browser to DFU device
Wrote 237 bytes
Manifesting new firmware

But no sounds out of any outputs.
Do you have any other idea I could try.
I’m at the point where I can’t spend more time with this unit and produce 0.
So i’m happy to try one last thing but then consider how I get rid of it.
I bought it from schneidersladen… but that was 4 months ago so I don’t know what to do with it.

Hi Sylvain,

Could you recap what’s not working and if there has been any changes?
And can you get sound out with the examples in the Daisy Web Programmer? EDIT: Ok, I think you were able to get this working?

I recommend giving the new plugdata a try. There was an update recently.

I think things are exactly the same as when I started.
To summarize :

installed plugdata 0.7.1
I try to flash blink.pd using these settings :
I get this error :

→ Generating C
AVX: 0 cycles / 0.0 cycles per frame
512 frames @ 1000MHz >= 0.00us
SSE: 0 cycles / 0.0 cycles per frame
512 frames @ 1000MHz >= 0.00us
CPU% #Objs Object Type Performance
==== ===== ================ ===========
→ Generating Daisy module

  1. e[91mErrore[0m c2daisy: Unknown parameter “led”
    Total compile time: 94.00ms
    Compiling…C:/Users/Sylvain/AppData/Roaming/plugdata/Toolchain/usr/bin/arm-none-eabi-gcc -c -mcpu=cortex-m7 -mthumb -mfpu=fpv5-d16 -mfloat-abi=hard -DUSE_HAL_DRIVER -DSTM32H750xx -DHSE_VALUE=16000000 -DCORE_CM7 -DSTM32H750IB -DARM_MATH_CM7 -DUSE_FULL_LL_DRIVER -include stm32h7xx.h -I…/…/libdaisy -I…/…/libdaisy/src/ -I…/…/libdaisy/src/sys -I…/…/libdaisy/src/usbd -I…/…/libdaisy/src/usbh -I…/…/libdaisy/Drivers/CMSIS/Include/ -I…/…/libdaisy/Drivers/CMSIS/DSP/Include -I…/…/libdaisy/Drivers/CMSIS/Device/ST/STM32H7xx/Include -I…/…/libdaisy/Drivers/STM32H7xx_HAL_Driver/Inc/ -I…/…/libdaisy/Middlewares/ST/STM32_USB_Device_Library/Core/Inc -I…/…/libdaisy/Middlewares/ST/STM32_USB_Host_Library/Core/Inc -I…/…/libdaisy/Middlewares/ST/STM32_USB_Host_Library/Class/MSC/Inc -I…/…/libdaisy/core/ -I…/…/libdaisy/Middlewares/Third_Party/FatFs/src -O2 -Wall -Wno-missing-attributes -fasm -fdata-sections -ffunction-sections -Wno-stringop-overflow -g -ggdb -MMD -MP -MF"build/startup_stm32h750xx.d" -std=gnu11 -Wa,-a,-ad,-alms=build/startup_stm32h750xx.lst …/…/libdaisy/core/startup_stm32h750xx.c -o build/startup_stm32h750xx.o
    make: *** No rule to make target ‘build/HeavyDaisy_blink.o’, needed by ‘build/Heavy_blink.elf’. Stop.
    make: *** Waiting for unfinished jobs…

(I don’t get the DFU in FS mode message … I think I used to saw it months ago ? anyway, I get :

Pd translation error:
[Errno 13] Permission denied: ‘C:\Users\pd2dsyGUI\data\util\daisy.json’

Daisy Web Programmer

  • connect DFU thing ok, Im’ connected then :
    flash Blink = led is blinking

  • refresh page / connect / load any exemple pd = work as expected

  • refresh / connect / select a pd from my pure data library (like the simple one we described above [osc~ 440]<[dac~ 1 2 3 4]
    I get as expected :

Erasing DFU device memory
Copying data from browser to DFU device
Wrote 162 bytes
Manifesting new firmware

but nothing goes out of any outputs.