Unable to program new Daisy Seeds

I’m using Windows 10, VS Code, Gitbash. USB

I can stll easily program older Seeds. None of the new ones work, I get this error every time:

Warning: Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
No DFU capable USB device available
make: *** […/…/libDaisy/core/Makefile:330: program-dfu] Error 74

Am I forgetting something?

Images of the old and new Seeds (slightly different) - https://imgur.com/a/ysp4Axv

Hi @adhocpsyop - this is a shot in the dark, perhaps Zadig will help:

Thanks. I installed Zadig and replaced the driver when I first set everything up. Zadig recognises and lists the new Seeds as “Daisy Seed built in” until I put them in bootloader mode, when it shows “Unknown USB Device - Device Descriptor Request Failed”.

I re-installed the driver again for “DFU in FS mode” and get the same message when trying to program the Seed. If I try to install the driver for “Unknown USB Device…” installation fails

So just to clarify this, I can easily program Seed version 1.1, but not version 1.2, which gives me the error above.

Anyone experienced this?

I just tested a v1.2 with Oopsy and the ES Daisy web programmer, and they both flashed as expected. Haven’t tried in bootloader mode…

I have quite a few programs written for the Seed in C++ (currently in Visual Studio) so I need to at least program v1.2 with an C++ IDE

Does the ST Link work with v1.2?

Is it still possible to buy v1.1 Seeds?

I’m puzzled by how the version (1.1 vs 1.2) can affect the programmability. They’ve both always worked interchangeably for me, on my Macs.

Are you sure you’re pressing the buttons correctly to place the Seed in DFU mode? Have you tried using the Web Programmer?

Thanks, Web Programmer is giving the same info as Zadig

ie. v1.1 works fine. But with v1.2, after clicking connect, no DFU option appears. if I don’t put v1.2 into bootloader mode, it shows in the Web Programmer connect window as “Daisy Seed Built In - Paired”

I’m certain I’m entering bootloader mode correctly, it works every time for the old Seeds but never with any of the 4 new ones I have

Maybe @Takumi_Ogata can offer a suggestion?

Thank you for reporting this issue.
I unfortunately haven’t seen other community members encountering this issue on Windows so far.

I can bring this up to the team and offer any suggestions that they have. I greatly appreciate your waiting.

Thanks, I look forward to your reply. It’s possible I’m forgetting something obvious… Do I need to make changes to software settings to program the v1.2? Is there something that should be done the very first time you program a Seed?

At the risk of sounding repetitious, are you doing the following steps to put Daisy in DFU mode?

  • Put your Daisy into flashable mode by holding down the BOOT button, and pressing the RESET button. Once you release the RESET button you can let go of the BOOT button (You’ll know you performed the button combo correctly if the USER LED on your Daisy stops flashing)

Note: that last line only applies if the Daisy came loaded with something like the Blink example. Yours apparently came loaded with something that enables USB, which is why it shows up as ‘Daisy Seed built in’.

Yep, that’s exactly what I’m doing to enter DFU mode. These seeds are blinking (until i enter DFU mode)

Interesting, yours are blinking, AND showing up with ‘Daisy Seed built in’?

I wish I had one of those Seeds here to try on my Mac. This MUST be some weird Windows USB thing. Maybe.

Yeah, blinking and showing “Daisy Seed built in”

If it comes to it and we can’t figure this out I’ll post you one of these seeds if you like

And pressing the buttons to enable DFU does STOP the blinking LED?

And pressing the buttons to enable DFU does STOP the blinking LED?


I was directed to this thread from Discord as I’m experiencing exactly the same issue so am logging it here.

I have rev5 (Seed 1.1) that are flashing just fine but I’ve recently received a batch of rev7 (Seed 1.2) and they give the error
No DFU capable USB device available
when trying to flash them. I’m using exactly the same set up, cable etc as the correctly flashing rev5 Seeds

I am getting the same issue when trying to flash from the web programmer, pd2dsy and plug data

I’m running Mac OS 12.1

Hoping there will be a solution found soon. Thanks

I have an Intel Mac on 12.6.8, and m1 Mac on 14.1.1.
On both, I can program rev5 and rev7 Seeds interchangeably.

On a Mac, I’d look in the USB section of System Information to see what’s going on with Vendor ID and Product ID on the rev7. And compare it with behavior on Rev 5. On my Seeds, several of each version, they behave identically.

Update here: I’ve upgraded my Mac OS from 12.1 to 12.7.2 and now the rev7 Seeds are recognised in DFU mode and flashing fine (phew!)

@tele_player thanks for your message. in case of interest I tried this (on both versions of the OS before and after I upgraded) and got this result from the USB section of System Information:

normal mode - nothing listed
DFU mode - ‘DFU in FS Mode’

normal mode - ‘Daisy Seed Built In’
DFU mode - ‘DFU in FS Mode’