Oopsy failing to Make, generate .bin, upload to Daisy

Don’t know how I did it but Oopsy is failing to complete
no Make, no .bin, no upload to device.
Daisy Web Programmer still working so Daisy is connected.

oopsy-verbose: oopsy generated code
oopsy-verbose: generated code
oopsy-verbose: Makefile:12: …/libdaisy/core/Makefile: No such file or directory
oopsy-verbose: oopsy done
oopsy-verbose: done
oopsy-verbose: make: *** No rule to make target `…/libdaisy/core/Makefile’. Stop.
oopsy-verbose: make failed

I tried deleting the Oopsy directory, re-downloading the branch ZIP and it had the same result
I also tried cloning the branch with GitHub Desktop
same result
:frowning:

Not sure why it would happen all-of-a-sudden like that, but if you recloned the repo it may be missing libdaisy (if you didn’t run the install.sh script, or do what it does manually).

It’s complaining about the build file for the project missing. You can check to see if it’s there or if the file/directory are missing by looking in Max 8/Packages/oopsy/source/libdaisy/core to see if there’s a file called Makefile.

If it’s missing, go back to the oopsy folder, and run ./install.sh that should fill the libdaisy folder, and then create the library file that oopsy needs to build the generated code.

1 Like

No idea what I did.
Recloned with Git
ran install.sh
Working fine now.

2 Likes

I have a similar problem here … I can upload examples from the web programmer but I cannot upload patches from MAX …
oopsy-verbose: script start patch 96kHz /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/examples/reverb.cpp
oopsy-verbose: stop success dictionary u325005937
oopsy-verbose: start success dictionary u116005938
oopsy-verbose: Target patch configured in path /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/source/daisy.patch.json
oopsy-verbose: Building to /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/source/build_reverb_patch
oopsy-verbose: Will upload from /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/examples/reverb.cpp by writing to:
oopsy-verbose: /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/source/build_reverb_patch/reverb_patch.cpp
oopsy-verbose: /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/source/build_reverb_patch/Makefile
oopsy-verbose: /Users/andreafiocca/Documents/Max 8/Packages/oopsy-main/source/build_reverb_patch/build/reverb.bin
oopsy-verbose: oopsy generated code
oopsy-verbose: generated code
oopsy-verbose: oopsy done
oopsy-verbose: done
oopsy-verbose: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
oopsy-verbose: make failed

1 Like

Do you have Make installed?

1 Like

I’ve made it ! I’ve installed Homebrew and all that crazy strange stuff that I’ll never understand and now it works !

2 Likes

For people having issues still, please see the chat I had with support: