Issue with Tab Reader & Writer on pd2Dsy

I have been having some issues getting PD2Daisy sketches working. I can get them to compile but other than the sketch made for the Petal I have not been able to get any other sketches to work with audio input.

I also have not had any luck getting the Tab Reader and Writer to work. I am wondering if anyone here has compiled some PD patches that work with things like audio in and the tabwriter etc.

I tried downloading a bunch of OWL pd files and changing the button names and input names but alas, I had very little luck.

any help appreciated as it seems so much of the talk on here is about OOPSY not PD2DSY .


Hey cricketbee!

I just saw this post pop up in the ‘latest’ and I hope I can help out! Sorry if you already had this all figured out.

So it sounds like Petal’s audio input is working since you were able to get the provided Petal example working, correct?

I just quickly put together a super simple patcher that consists of tabwrite~ and tabread4~.

Let’s remove adc~ from the equation for now. This program plays the internally recorded sawtooth whenever I press a button on my Daisy Pod.

See if you can get something like this working on Petal. Then you can start adding audio input, buttons for start/stop recording, and etc. :slight_smile:


thanks for your help but I do not have a petal! i simply copied the PD file and changed the names to be POD appropriate.

however I will try to make a pd file which copies what you did and I will try that! your help is much appreciated

1 Like

Hi, I am using the daisy pod with pure data, but i would like to use also extra sensors (flex and sonar). How do I read the analogue and digital pins in pd2daisy? I could not find any conversation about this. Is there an easy schematic of the GPIOs for the daisy pod?
Thanks a lot.

I would be happy to help!
But, I would appreciate it if you could start a new thread for it. It’ll be more organized that way and also may help other users in the future.
Thank you!

1 Like

ok will do thank you.

1 Like

I am able to get a a few examples working (I am now using PLUGDATA which seems to be much easier to get working)

however I have noticed a few troubling things. 1. any patches which show the LEDS do not seem to light up s led2 @hv_param which is connected to r button2_press @hv_param does nothing on my POD.

The other troubling thing is that when I load a pd patch the Led makes a POP and emits a super bright white light for a second while the patch is being transferred to the board. is this normal?

Mainly at this point I would love to find any examples for POD , PAtch Sm or Patch that show using delays or tab read/write etc



Hey Dan!

Let’s go one topic/question at a time :slight_smile:
And I suggest starting a new thread for a question that’s different from the original topic. That way, other users can see the title and may know the solution and help out! Thanks!
Also, please remember to include a screenshot or a file of the patcher too.

Since the second question is related to the original topic, I would be happy to continue!
Could you share a screenshot or a file of the patcher? My guess is that you’re using a lot of delays and Daisy is being “overloaded” with buffers.

It happened with my Pod before where I flashed a patcher that had several delay lines with large buffers. The file itself is small enough to fit inside of Daisy, but once it’s embedded, both of the LEDs became fully white and bright.

So my suggestion is scaling down the patcher (or scaling up from a single delay line with small size) and go from there!

1 Like

Also–sorry the reason I was used to putting everything in one topic is that for awhile questions on PD were taking a long time to answer or often were all put into one long topic on PD2DSY. I will begin using only one topic at a time now as it seems they are getting answered more directly -thanks

1 Like

and I will get back about this topic after I post the other one ) thanks for all your help

1 Like

Ok in response to the TabReader and Writer you made—I tried to re-draw it based on your image… and loaded it with Plugdata…it DOES load but i get no sound on my Pod-- can you see anything wrong with it?

Ok, it looks exactly the same as the patcher that I shared so that’s interesting.

Related to your other issue (maybe it was all related afterall?), could you flash this patcher using the terminal method? I know that the PlugData method is more convenient, but it’s the one main difference between my setup and yours.
I can guarantee that both the podtest.pd and the patcher I shared in this thread worked with my Daisy Pod when flashed via the terminal.

Re-visit that method and see if you’re still having issue.

So i have been having a very hard time getting PD2DSY working without PlugData

I tried installing and using the PD2DSY GUI setup according to the electro-smith guide but i got errors no matter what i tried to do (i could not even get the gui to open)

I already have python 3 installed so I am wondering if it caused a conflict

but plugdata does work and it puts out the same output so maybe I could just show you the output or better yet maybe I could send you my PD file and you could try it on your pod?

i am worried I may have a bad Pod because as i said before every-time i load to it with PD2DSY it makes a pop and the LEDS flash very bright for a second…maybe this is normal though


ast login: Sat Feb 18 10:21:36 on ttys009

/Users/cricketbee/Downloads/pd2dsyGUI_macos_v3-ARM/pd2dsy_gui/pd2dsy_gui ; exit;

**➜** **~** /Users/cricketbee/Downloads/pd2dsyGUI_macos_v3-ARM/pd2dsy_gui/pd2dsy_gui ; exit;

[17425] Module object for struct is NULL!

Traceback (most recent call last):

File "", line 13, in <module>

ImportError: dlopen(/Users/cricketbee/Downloads/pd2dsyGUI_macos_v3-ARM/pd2dsy_gui/lib-dynload/, 0x0002): tried: '/Users/cricketbee/Downloads/pd2dsyGUI_macos_v3-ARM/pd2dsy_gui/lib-dynload/' (code signature in <0137C074-F77D-360D-99D2-155D66303A54> '/Users/cricketbee/Downloads/pd2dsyGUI_macos_v3-ARM/pd2dsy_gui/lib-dynload/' not valid for use in process: library load disallowed by system policy), '/usr/local/lib/' (no such file), '/usr/lib/' (no such file)

[17425] Module object for pyimod02_archive is NULL!

Traceback (most recent call last):

File "PyInstaller/loader/", line 27, in <module>

ModuleNotFoundError: No module named 'struct'

[17425] Module object for pyimod03_importers is NULL!

Traceback (most recent call last):

File "PyInstaller/loader/", line 23, in <module>

ModuleNotFoundError: No module named 'pyimod02_archive'

Traceback (most recent call last):

File "PyInstaller/loader/", line 17, in <module>

ModuleNotFoundError: No module named 'pyimod03_importers'

[17425] Failed to execute script 'pyiboot01_bootstrap' due to unhandled exception: No module named 'pyimod03_importers'

[17425] Traceback:


Saving session...completed.

[Process completed]

If you suspect a bad pod, use the Web programmer to load some of the pre-built examples.
It’s more likely that it is user error, or bugs in the various work-in-progress software involved in getting Pd files to run on Daisy.

thanks–what is strange is that all the test examples work fine but the sketch that Takumi sent me which i re-drew exactly def does not work

So my first thought was not that my pod was bad but that there is something that might be set wrong. I have no issue with getting the basic examples to work but they are so basic that as soon as I tried doing anything more substantial I ran into new issues which I was never sure what the problem might be (i have another thread open where I could not get the buttons to trigger the LED )

I think what’s more worrying than my tab patcher not working is the pod_test.pd acting buggy on your Pod.

Just in case, try this new web UI that was built by adj555 I built a web UI in front of pd2dsy!

Also, let’s focus on one issue at time, it’s gonna start to feel overwhelming. Let’s deal with the POD LED situation first before continuing here.

1 Like

Suggestion: where possible, post actual .pd files, rather than screenshots. It’s easy to make a mistake trying to duplicate a patch from an image.

1 Like

Good point.

Here’s the patcher, Dan!

While at it, here’s the patcher for your other inquiry.

thanks a lot-i did not know we COULD post actual PD files so from now on I will :slight_smile: I will test later today

Ok some progress here
i am happy to say the tab write and read works!!

the other sketch did not light up the leds and i will continue that in the other thread

1 Like