Issue with Git Not Installing Properly On Windows


  • I cannot get a GIT-bash terminal in vs code
  • running make in the git-bash itself gives me an error
  • I also tried the web programmer, buttons are greyed out with an error in the console

can someone look at this issue I just created ? thanks for your help

nothing works · Issue #571 · electro-smith/libDaisy (

any help appreciated

Hi Phil!

Could you tell me more about “I cannot get a GIT-bash terminal in vs code”?
Are you talking about the step with New Terminal → Select Default Profile → Git Bash not working?

Also, did you follow the Zadig step for resetting your USB driver?

I set it up on Windows few weeks back for this video that came out last week, so triple check that you didn’t overlook a step.

I can look at your errors more closely and may come back later if I have any suggestions.

Also check out this thread just in case (especially towards the end).

that video just repeats what I already been through

and as I said, there is NO GIT BASH TERMINAL in vs code

as I run git-bash from dos command line

$ task build_and_program_dfu
bash: task: command not found

also there is no DFU option in Zadig

can you READ THE ISSUE in github please ???


Just double checking with you, but did you put Daisy into bootloader mode? That might explain the "DFU in FS Mode” not showing up.

yep, but fefore that I asked on reddit since I cant have a response here
No way to get Git-bash as a terminal : vscode (

what about people not using vs code ?? how do you build on the command line ?

You build on command line by typing ‘make’.

I’m an old school Unix user, running this on an old MacBook Pro, and my normal workflow is edit using ‘vi’, build by using ‘make’, USB upload to Daisy with ‘make program-dfu’, or STLINK upload using ‘make program’.

First step is to get Web Programmer working, use Chrome.

Hey Phil,

I’m doing my best here. You did ask multiple things, so I’m trying to answer ones that I can at the moment.

As @tele_player said, let’s first get the Web Programmer working. Is the button still greyed out after putting Daisy into bootloader mode? If so, could you please check if the “DFU in FS Mode” is showing up in Zadig.

Thank you.

make returns “cannot find daisy library”

and my screenshots (on github) are from chrome

yes and I appreciate it, yet

  • one thing at a time, I dont have connection issues AFAIK
  • apparently posting on github does not help, people dont read all the infos I posted

Could you confirm to me that “DFU in FS Mode” is showing up after putting Daisy into Bootloader mode?

I did read your github post and I’m addressing the issue that you are having with the Web Programmer right now.

it did show up indeed. thanks

now how do I build the library ? (WITHOUT VS code)


I finally have a git bash terminal, (git must be installed on c:\ and no other drive…come on)

yet daisy library cannot be found
I cannot believe such a hello world type example is so difficult to put into practice

Glad to hear that it’s installed!

I recommend re-following the steps after setting Git Bash to default profile (especially the step task build_all cannot be skipped).

Also for this error, make: *** [../../libdaisy/core/Makefile:252: program-dfu] Error 74
The solution is to ensure your USB cable is connected properly, and your Daisy is in DFU mode.

To put your Daisy in DFU mode, hold the BOOT button down, then press the RESET button. Once you release the RESET button, you can also let go of the BOOT button.

Let me know if you got it working after those.

I get that error 74 even after upgrading the drivers and right after entering bootloader mode

We’re getting closer than when we started, Phil.

  1. Could you confirm with me that you followed these steps:
  • Select Default Profile, then choose Git Bash

  • Open the Blink example’s folder in VS Code by clicking File > Open Folder, then navigating to ~/Desktop/DaisyExamples/seed/Blink

  • Put Daisy into Bootloader mode

  • Launch the command palette with Ctrl+P

  • Type task build_all

  • Launch the command palette with Ctrl+P again

  • Run task build_and_program_dfu

Please don’t do anything different than what’s stated here.

  1. And could you send me a screenshot of the Zadig with “DFU in FS Mode” displaying?

I recloned it with

git clone --recurse-submodules

and now it works

who store his work in ~\Desktop ??? what is this ?

Great! I’m glad it works now!