Difficulty uploading via Arduino (OSX)

So I’m stuck and hoping someone here can help.
Using arduino IDE 1.8.19
I have gone through the “getting started” wiki, installed the proper boards, libraries, etc…
Installed the horrible disaster that is STM32CubeProgrammer, I think (it opens and shows in the arduino IDE).
Created a new path in terminal etc…
Configured everything in the Arduino IDE
So far so good.

I finally have made it to the point of actually uploading an example,
Open a file, set the daisy seed in boot mode and hit upload.
Everything seems to go well, no obvious errors,

here is the output from the IDE

"Memory Programming …
Opening and parsing file: Sequencer.ino.bin
File : Sequencer.ino.bin
Size : 77.32 KB
Address : 0x08000000

Erasing memory corresponding to segment 0:
Erasing internal memory sector 0
erasing sector 0000 @: 0x08000000 done
Download in Progress:

File download complete
Time elapsed during download operation: 00:00:01.536

RUNNING Program …
Address: : 0x8000000
Start operation achieved successfully"

And I get the “Done uploading” message.

However, nothing happens. The Daisy patch just sits there. No output, nothing displayed on the screen etc…
It works fine uploading from the daisy web programmer.

So, any thoughts? The lack of any type of error messages mean I really don’t know where to look at this point.


Have you tried pressing the reset button after flashing your code?
I just tried flashing the same example, and I had the same experience!
It works after you press the reset button though.
At some point our Arduino examples started doing this, though I’m not sure why.

If that doesn’t solve it, let me know and we can work through some other troubleshooting steps.

1 Like

Hi Ben,
Just gave this a try and yes this seems to have fixed it.
: )


1 Like

Ben, I’m seeing this same behavior using the DFU flash utility. The reset button must be pressed after flashing code. I am working with the PatchSM and it is rather incoventient when the module in an Eurorack case. Is someone looking into this?

I don’t know whether someone is ‘looking into this’, but there is some info regarding hooking up an external reset button in
Hardware reset button

that might be worth doing.

If you use flash over JTAG(SWD) using the ST Link debugger or comparable, you won’t have to press any buttons when flashing firmware.

You may need to install the JTAG on your Patch SM if you have not done so yet.