Which macOS for the Oopsy toolchain?

Hello,

what are the macOS versions you use with the Oopsy toolchain and gen~ in Max?

I tried with my macOS Sierra (10.12) but had no luck. I don’t feel too excited updating to the latest OS for this, cause I have a macbook late 2013

I already tried the blinking light demo with the daisy web programmer and made sure my daisy seed was working
https://electro-smith.github.io/Programmer/

but i wasn’t able to use it with a max patch with the latest Max 8 and macOS Sierra (10.12)

(for those wondering: I posted this on modwiggler already, but thought it might be better to get an account for the Daisy Forum)

Hi,

Until recently I was using Oopsy on OSX 10.11, but recently upgraded to 10.14 (against my better wishes…)

Oopsy worked fine in both.

Usually if there are problems it could be one of either:

    1. Multiple copies of the Oopsy package in the Max 8/Packages folder, or somewere else in Max’s search paths,
    1. A problem installing the compiler toolchain – the web programmer doesn’t use these (hence it not being a problem there). See the instructions at 1b. Installing the Toolchain on Mac · electro-smith/DaisyWiki Wiki · GitHub in particular! It’s a bit fiddly to get it going, but once it works, it stays working.

Graham

thanks a lot graham. i used the web programmer to make shure the daisy seed is working (isolating the problem). great to hear you got it going with an even older OS. i had a few errors and warnings while installing the toolchain so i thought it must be the problem. some stuff didn’t get installed or updated. will try some more

I had some time today and figured it out. I thought I share my solution, which might help someone. Like I said before, my macOS is 10.12.6, so maybe thats the reason why it didn’t install the dfu-util library automatically.

what i did to be able to recognise and solve this:

  • In my Max template for my Bluemchen, I deactivated QUIET and BOOST
  • while trying to get my patch on my Bluemchen i got the error that dfu-util couldn’t be found
  • I downloaded dfu-util-0.11-binaries via the link that Graham posted before and unpacked it
  • under usr/local/bin i put the dfu-util file
  • under usr/local/opt/ i created a folder libusb/lib and put the libusb-1.0.0.dylib library in there

still got this warning though:
oopsy-verbose: stderr dfu-util: Warning: Invalid DFU suffix signature
oopsy-verbose: dfu-util: A valid DFU suffix will be required in a future dfu-util release

cheers

That “Warning: Invalid DFU suffix signature” is nothing to worry about – it always says that. You’re good to go! Thanks for sharing the steps.