Web programmer not working with patch.init()

Note that this is the first product that I’m trying so I haven’t gotten this working with daisy seed or otherwise.

While I am able to get to a point where, after clicking ‘connect’, google chrome shows ‘DFU in FS mode- paired’, the program buttons remain greyed out even after I select a device type and binary to flash. Flash Blink! remains disabled.

Notably the ‘Connect’ button does not grey out as I would expect it to after making a connection. How do I work around this?

Currently using Ubuntu 18.04. I tried to connect with windows but the device didn’t even show up in the selections- at least I got as far as I did on linux.

Sorry to hear that! Are there any errors in the console? You can open it with F12 I’m gonna take some time to test the site on my Linux computer today for you.

Regarding the Windows issue, did you reset your USB driver with Zadig? If not, there’s instructions to do that here. Maybe the site will work there if we can’t get it working on Linux.

2 Likes

Okay, fixing the driver and flashing from windows has worked for me. Thanks- but let me know if you can get it working on linux too!

1 Like

I’ve been using the ‘make program-dfu’ from linux and in the DaisyExamples folders. Using the CLI fits the linux workflow really nicely for me. Leaving this here just in case other linux users want an alternative.

Glad windows is working out for you!

I can confirm the site isn’t working on Linux, I’m looking into a fix now.

1 Like