Vscode not finding arm-none-eabi-gcc under linux

Hello there,

I am setting up my environment for the daisy right now. I was able to build the daisy example folder in my terminal via the ./rebuild_all.sh script.
I tried to build it from vscode without success. The task build_all command stops with the following error:

make: arm-none-eabi-gcc: No such file or directory
make: *** [Makefile:358: build/Drivers/STM32H7xx_HAL_Driver/Src/stm32h7xx_hal.o] Error 127

echo $PATH gives me the correct folder and arm-none-eabi-gcc --version outputs the correct version. I think ~/.bashrc includes the correct path. Any ideas why I can not build from inside vscode?

I think I solved this. This thread helped me: https://stackoverflow.com/questions/54653343/vs-code-refresh-integrated-terminal-environment-variables-without-restart-logout

Seems like environment variables only get proper reloaded when once starting vscode from within one of the external terminals. once I did this I now can use the task build_all and task build_and_program_dfu.


I discovered the same when using pd2daisy. arm-none-eabi-gcc is only available when starting pd2daisy_gui in my terminal.

Glad to hear that it’s working! And thank you for outlining the solution.
Have fun with the Daisy!!