User LED no longer lights


Hi have two Daisy Seeds, one very new, both have been spending their time well looked after in breadboards. Neither will connect to the Arduino IDE any more, and neither will go into Bootloader mode. The USER LED on both doesn’t light up, only power.

I’ve changed USB cables, and double checked the USB cable will carry data, so that’s not the problem.

Can anyone help? Are these boards dead?

Hi @instasquid - Can you try using the ‘web programmer’ to program them with one of the example programs? That way we isolate the problem - it could be the Arduino IDE has a problem.

I don’t think the user LED being off is an indication that the board is dead. It just means no user program is turning the LED on.

1 Like

It is! Good to know.

I did try the web programmer before posting, but I tried it from Firefox which is obviously never going to work. I switched to Chrome and uploaded the blink sketch to them both. So that works. Thanks! What a relief!

Given they were working with the Arduino IDE and then stopped what is the recommendation on what should I do from here? Stop using DaisyDuino?

If the Web Programmer is working, then you can be sure that your Daisy is working :smiley:

Your Daisy can go into the bootloader mode as long as it’s powered.

Could you tell me more about what’s indicating that the Arduino IDE is not recognizing the Daisy?

Please double check that you have the settings all configured.


Most importantly, the User LED will be off after putting the Daisy into the bootloader mode. Please try uploading the blink example and see what happens :slight_smile:

1 Like

It really depends on what you’re doing-learning with Daisy. I was a bit surprised you’d be willing to give up DaisyDuino. So here’s some ‘general thoughts’: If DaisyDuino was doing what you wanted before, I have confidence that with the guidance of @Takumi_Ogata you can-will get it working again.

If you want to do more ‘bare metal’ audio programming I’d try C++, perhaps with vscode as your IDE,

If you want to get more ‘abstract’ and work-play with audio-music with less ‘computer stuff’ you could use some of the Daisy tools that let you use ‘Pure Data’- like pd2dsy and its web related stuff-Plugdata. But you don’t need Daisy to use Pure Data - It will run on a PC, or Mac, or Linux machine such as Raspberry Pi or even RISC-V!

Far out!


Thanks to this I’ve worked out my problem, which is completely on my side. The Daisy used to show up with a com port, and that has stopped. I just assumed that would stop me being able to upload code, but it clearly does not.

Thanks for the quick response, Takumi! I appreciate it.

1 Like