Uploading thru Arduino IDE

Hey everyone, I’m trying to get things setup with my Pod and it seems my settings aren’t right to upload from arduino IDE to the daisy. When I try to compile I get “Error compiling for board Generic STM32H7 series”, could someone post a screenshot of the proper settings?

As an update, I’ve tried uploading 2 different examples from the DaisySP library and I get the same compiler error both times. All settings match the startup guide for Arduino

Hi @banjomasterpete! Sorry to hear you’re having a rough time. Could you post the errors you’re getting when trying to compile, and what OS you’re running? If all the console is telling you is what you posted you can enable verbose logging in your arduino settings.

Other things I would recommend are

  • making sure the daisy is in bootloader mode (holding boot and tapping reset)
  • ensuring you installed Stm32CubeProg (and added it to your PATH, if relevant)
  • trying compile a generic arduino example (i.e. Blink)
  • attempting to compile an example from the Daisy Audio library
  • making sure that your DaisySP library has been installed correctly, and the source files are in place (we will upload a downloadable arduino library ready to run sometime this week to make it easier for those unfamiliar with git)

Hope that helps

@shensley here’s the verbose output (removed personal info from filepaths), I’m running windows 10:

In file included from \ArduinoOffline\libraries\ArduinoDaisySP-master\examples\oscillator\oscillator.ino:2:
\ArduinoOffline\libraries\ArduinoDaisySP-master\src/DaisyDSP.h:4:10: fatal error: utility/DaisySP/daisysp.h: No such file or directory
4 | #include “utility/DaisySP/daisysp.h”
| ^~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.

Using library ArduinoAudio-master at version 0.1 in folder: \ArduinoOffline\libraries\ArduinoAudio-master
Using library ArduinoDaisySP-master at version 0.1 in folder: \ArduinoOffline\libraries\ArduinoDaisySP-master
exit status 1
Error compiling for board Generic STM32H7 Series.

I have both the DaisyAudio and DaisySP libraries installed. I just installed the stm32cubeprog (I think?), most of the instructions make no sense to me. The Arduino Blink sketch uploaded just fine but DaisySP examples won’t. I also tried uploading the PatchSine example and here’s what I get:

USB speed : Full Speed (12MBit/s)
Manuf. ID : STMicroelectronics
Product ID : DFU in FS Mode
SN : 200364500000
FW version : 0x011a
Device ID : 0x0450
Device name : STM32H7xx
Flash size : 2 MBytes (default)
Device type : MCU
Device CPU : Cortex-M7

Memory Programming …
Opening and parsing file: PatchSine.ino.bin
File : PatchSine.ino.bin
Size : 53652 Bytes
Address : 0x08000000

Erasing memory corresponding to segment 0:
Erasing internal memory sector 0
erasing sector 0000 @: 0x08000000 done
Download in Progress:

File download complete
Time elapsed during download operation: 00:00:01.334

RUNNING Program …
Address: : 0x8000000
Error: Start operation failed
Invalid version found: version 2013-07-07-17:51
Invalid version found: version 2013-07-07-17:51

Ah, It looks like you downloaded your libraries from github. They DaisySP library requires the contents of the C++ DaisySP github repo with the examples removed.

You should be able to download the zip of the repo at that link (examples already removed), and place it’s contents inside of the src/utility/DaisySP folder.

I’m going to try to get a static zip file uploaded somewhere this week that can be downloaded instead of using github for those who aren’t familiar with it.

Hope that helps!

@shensley there it is, that did the trick! Thanks for the help

Hello, I’m running into the same issue, is the solution described from 11 months ago, still applicable?

Arduino: 1.8.13 (Mac OS X)
Board: “Generic STM32H7 Series
Daisy Seed
STM32CubeProgrammer (DFU)
Enabled (generic ‘Serial’)
CDC (generic ‘Serial’ supersede U(S)ART)
Low/Full Speed
Smallest (-Os default), Newlib Nano (default)”