Unusable Midi on Pod?

I am preparing for some gigs coming up in Europe soon and was hoping to use my Daisys with the Octatrack for my set

Yesterday I loaded up the PocketD Osc which was ported to the Pod and proceeded to have nothing but issues using it with the Octatrack Midi Out. I hooked up midi with the adapter provided by Electro-Smith

Then I thought I would try with the MIDI example in the Pod library. However this was even worse.

I made sure to turn off all clock and other parameters which should pass from the Octatrack. I can get the first note to trigger but then it becomes unreliable and a mess.
I have heard from others that the Pod Midi library may have issues and to use the old one but I am not sure which one to use.

Has anyone else gotten reliable Midi working with the Pod and if so any help is greatly appreciated.

Sorry you’re having trouble!

The good news is this issue is known, and was fixed relatively recently. (It’s possible you’re experiencing a different issue, but the one I linked was first reported from an Octatrack user, and your bug report sounds exactly the same.)

Hopefully updating libDaisy and rebuilding / reflashing will fix the issue.
Let me know if you need help with any of that, and I’d be more than happy to help walk you through the process! If updating doesn’t fix your issue, we can work through that situation as well.

THANKS i will check it out :slight_smile:


no luck so far with the pod :frowning:
I had already updated to 5.1 but I was hoping that if I did make clean and then make again i would see an improvement. So i can now confirm that midi from the 5.1 lib is def not working with my POD

I tried with two different seed modules which I put into the Pod --neither one made any sound at all with MIDI from the octatrack or the beatstep pro.

I DID get midi to work on the PATCH but the only thing that works is the example sketch which has no note off and is a constant tone. I may try to work on that but i am almost out of time so if anyone knows of a midi synth for the patch i would be so appreciative!

THANKS A MILLION…I was able to take the code from your github link and paste it into version 5.0

and rebuild

tests show that IF i take all the code from the MIDI FIXES PRS and paste them into libdaisy ver 5.0 WITHOUT any other changes, the MIDI works GREAT on the POD> so it must be something else in the 5.1 update that breaks Midi capability on the pod

by the way any idea where the original post was? I tried to use a midi monitor to figure out what the octatrack was spitting out but of course all it showed was note on and CC data not status bytes :frowning: anyway have a good recommendation for how to view ALL midi data ?


Glad to hear it’s working!

The PR I linked fixes an issue with “running status”. Basically midi messages consist of bytes, with a note on being 3 bytes. Something like (Note On, channel) (note) (velocity). That first byte (Note On, Channel) is the “status byte”. With running status, if you have another midi message with the same status byte as the last one, it will just send (note) (velocity), and the parser will have to infer that it is the same type of message as the last one (Note On, channel). This PR fixes an issue with how the libDaisy midi parser was handling those running status bytes with note on and note off messages.

That being said, a midi monitor is doing the same running status parsing, so you won’t actually be able to tell if running status is occurring without looking at the raw bytes.

As for the 5.1 issue: something with our UART update broke midi, which is unfortunate because it was bundled with the midi fix mentioned above! We’re currently working on fixing that issue.

@cricketbee The issue should be fixed now as of this merged PR. You can pull and rebuild the latest version of libDaisy, and everything should work. Thanks for your bug report!

thanks! what is weird is that the elektron digitone does not cause this issue just the octatrack. I wonder if Elektron is aware of the issue