STM32_Programmer.sh not found. When loading code from Arduino IDE

Hi there :slight_smile: ,
When i try to load a program from Arduino IDE on Ubuntu 20.04 i get this error, even if ‘the/path/to/the/bin’ is in the PATH variable… I added it on the .pam_environment file as instructed by Ubuntu.
In fact if i just type STM32_Programmer.sh from any location using my shell, i get the sh running.

The error:
STM32_Programmer.sh not found. Please install it or add '<STM32CubeProgrammer path>/bin' to your PATH environment: https://www.st.com/en/development-tools/stm32cubeprog.html Aborting!

I’m confused… :confused:

1 Like

There are some notes about getting the Cube Programmer to work in Ubuntu, in this PDF from ST: https://www.st.com/resource/en/user_manual/dm00403500-stm32cubeprogrammer-software-description-stmicroelectronics.pdf (See 1.2.1 Linux install)

Maybe that helps?

You could also look for setup guides for STMduino in Linux in general.

1 Like

I did install Cube Programmer, i can launch it without problem.
And even stm32duino is correctly installed on my arduino IDE.
Still, i get this error. :worried: .

If you haven’t got it working properly in 2 days, you should probably just install it to default location since stm32duino would check that. Don’t forget to curse STM32 software department!

1 Like

What do you mean by “installing to default location”?
(Big curses from my side :angry:)

I happened to install it just yesterday for another board, ran into similar issues. Their installer uses default path “~/STMicroelectronics/STM32Cube/STM32CubeProgrammer/” that is checked by stm32duino, if you use custom location you should be modifying your PATH (which somehow doesn’t work for you). So just reinstall to that default path.

Not using custom location though. My installation is exactly at

~/STMicroelectronics/STM32Cube/STM32CubeProgrammer/

This is very strange. I can confirm that with that path it works on Linux, however I’m not using Ubuntu. I recall it was installing arduino as snap package, so it looks like it may be restricting access for arduino process. You could try opening issue in their tracker - https://github.com/snapcrafters/arduino/issues

Yes I was thinking the same about the Snap package, it is just gut feeling though because i did not find anything relevant on if snap installations behave differently regarding the PATH. I’ll try to install Arduino ide in another way just as a sanity check.

Guys I confirm that the problem was the Snap installation :grimacing:.
I highly suggest to add a few line about that in the wiki. At least until this is fixed.

Hi there… I’m going through the same nightmare!! I need help traversing the valley of the shadow of Arduino!

I have the .sh file installed in the default location, I downloaded Arduino from their website and installed. But I still get the same error! I tried downloading Arduino from the Linux Software desktop app, but still, same error messages!

I tried adding $PATH to the bashrc file but no joy

I’m banging my head against a wall… can someone help me out!

Cheers

Will

1 Like

maybe @francesco can help here? we have things working with Arduino and Windows, but this seems to be a Linux or even Ubuntu specific problem. Something about Snap installation - Francesco can you elaborate what you did to get things running?

Hi @will20fitz,
Can you share your linux distro?
I’m not sure about the meaning of that phrase:

What did you write on the bashrc file?

I’m asking those questions because from my experience the problem was the Snap installation, but that can’t be your case, since you installed the IDE from the website.

thanks for looking into this…

I’m on Ubuntu 18.04.4 LTS.

Memory 5.7GiB
Processor Intel Core i3-3110M CPU@2.40GHz x 4
OS Type 64-bit

I put this into the bashrc file.

export PATH=$PATH:/usr/local/STMicroelectronics/STM32Cube/STM32CubeProgrammer/bin/STM32_Programmer.sh

Looking online, i was under the impression that this would help Arduino pick up the STM32CubeProgrammer.sh … but perhaps not!

right… i have no idea what happened but i uninstalled Arduino and the STM32.sh
I then reinstalled Arduino from the Arduino website.
I had an issue as below:

ln: failed to create symbolic link ‘/usr/local/bin/arduino’: Permission denied
Adding symlink failed. Hope that’s OK. If not then rerun as root with sudo.
done!

so i installed as

sudo ./install.sh

This went ok.

I then followed https://github.com/electro-smith/DaisyWiki/wiki/1a.-Getting-Started-(Arduino-Edition) and i can now blink at any ms rate that i choose!

I dont know what was different about this installation and i hope that nobody has the same problem i had.

Right, now to program some Audio!

Thanks for your help everyone.

Will

2 Likes