ST-link v3 mini help

Hi, i just got my st-link v3 mini i purchased from electrosmith, i’ve been following the steps with a fresh new example project and i’m getting an error when i try to run task build_and_program aka make clean; make; make program

I’ve looked at similar topics but they dont seem to apply to this scenario.

Here’s my error:

Open On-Chip Debugger 0.11.0
Licensed under GNU GPL v2
For bug reports, read
Info : auto-selecting first available session transport "hla_swd". To override use 'transport select <transport>'.
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
Info : clock speed 1800 kHz
Error: open failed
in procedure 'program'
** OpenOCD init failed **
shutdown command invoked

really not sure what’s wrong

I was able to recreate the same error code by trying the command without my debug probe connected over USB. When you plug the debugger into your computer does a file explorer window open up? Are there red / green lights lit up on the debugger? Maybe you could try a different USB cable.

If that all looks good we can work through some other troubleshooting steps. Hope that helps!

1 Like

Lol amazing, that fixed it! Thank you :heart: