Patch working in prototype, but not on the Pod

Hi, hope this is the right place to post for help. I’m following @soundsimulator’s great YT playlist and experimenting as I go. This patch works fine on the prototype (the 1 and -1 messages change the freq by one semitone as expected) but not on the Pod (it just plays 440 Hz and won’t change.)

I’ve verified the Encoder works with other basic examples, and I just can’t see what I’m doing wrong here. I assume it’s a trigger problem, or something to do with the order I’ve connected hot and cold somewhere but I’ve been through it a dozen times and can’t fix. Every time it works on my laptop (in Purrdata and Plugdata) but not on the Pod.

Any hints would be greatly appreciated, thanks.

You should probably use an [osc~] instead (or use [hv.osc~ saw] to get a saw wave oscillator), since the [phasor~] is not meant for generating audio.

Also you’ll want to make sure to send a signal to control the frequency, so convert the control message with [sig~] for instance.

1 Like

Thanks… I’ll give those a go. What do you mnean by control message?

It is the difference between the continuous ___ and dashed --- lines that are going into blue and orange (resp.) inputs.

Continuous lines are control messages, dashed lines are signal. In the Heavy Compiler it is best to use signals into objects that expect signal (orange) input. In Pd you can often use both, but in the compiler this doesn’t always work well.

[edit: I just realized you are not using plugdata, but perhaps purr-data? My description of lines and inlets relates to how plugdata shows things]

1 Like

Yep, I saw what you meant as soon as I fired up PD… thanks. I see the difference in the inputs and outputs and on the lines now. Just going to try a compile and flash! :+1:

I was using plugdata, but tried purr-data & pd2dsy in case there was something wrong in my setup, and that’s where I took the screenshots

1 Like

It still wasn’t working as I want, even when I completely redrew it in a new patch.

I added [r encswitch] into the [2] message and now it triggers whenever i click the encoder, playing the new value, which sort of works for me, but I want to know why I’m not getting continuous changes.

I tried changing the [t b f] to [t f b] and I tried re-attaching all the cold inputs first… still not quite right.

You could also try it like this:

I don’t have a pod so I’d need to dig up a rotary encoder and try and build a setup myself to try.


That version works perfectly… It must be something I got wrong in the [t f b] and [pow] order I think. Something’s not triggering.

Not only that but your’s is neater overall.

Anyway… learning all the time. Thanks for your help.

1 Like