Patch Submodule/init - Can't enter the bootloader

Hey y’all,

I ordered a patch.init() a while back and finally got around to wanting to push some code to it and explore the platform a bit better. Unfortunately, I cannot for the life of me get the BOOT/RESET button combination to either get the LED to flash or the board to show up in the web programmer.

Before assuming my board was DOA, I just wanted to make sure I’m not missing something utterly obvious, so here’s a few things to note and that I’ve tried:

  • LED light stays on when USB is plugged in, no flashing

  • Pressing the 2 tiny white buttons on the back of the Patch

  • Trying just about every combination of time pressed and which to release first

  • Doesn’t work attached to init, removed from init, with or without modular power, multiple micro-USB cables that work with other data+power devices.

  • Updated driver with Zadig process just in case, nada.

Did I perhaps just get a bad unit? Or am I monumentally stupid? lol

Thanks in advance for the help!

Just a bump in case this was missed.
For more transparency, I bought this almost solely for part of a video feature on DIY and want to give DAISY its fair shake.

Hey, I just set up my patch.init() the other day so maybe I can help you out.

Mine did not come with the bootloader preinstalled, so you won’t see flashing LEDs until the bootloader has been installed.

Even without a bootloader, you can put it into DFU mode by holding the BOOT button and pressing RESET. Visually nothing happens, but at this point you will be able to flash something onto the device using the web programmer (or command line tools).

In the web programmer click “connect” and choose the “DFU in FS Mode” device. Then go ahead and program your patch.init() with one of the examples.

If you want to install the bootloader, then click “Advanced…” and “Flash Bootloader Image”.

3 Likes

Thank you! I’ll give this a try.

@alphabasic Sorry to hear you’ve been having a rough time!

You mentioned that you had already updated the driver in Zadig, which would make it seem like the board is connecting. On windows, the correct driver setting for the Daisy to be updated should look like this:
image

In my experience any version of WinUSB will work fine.

From there you should be able to find “DFU in FS Mode” in the menu as pointed out above, as shown in this screenshot:
image

If it’s not showing up there, double check the Zadig settings, and make sure you’re using a Chrome browser.


Also, to clarify, the “System Bootloader”, accessed as “DFU in FS Mode” via the button combination, is permanently installed on every daisy, and will always be there. This is what nearly every example program is compiled to work with.

The “Daisy Bootloader” available in the “Advanced” section is not required to load most programs (if so, it is specified in the program information). That bootloader is meant for more a different application structure providing different memory access, and alternative firmware update solutions.
All of the Patch SM examples are built for the default, system bootloader accessed as “DFU in FS Mode”

Looks like it worked. Thank you so much for your help!

1 Like

thanks for that. worked for me as well. thought it was dead…