Params for Oopsy + Daisy Patch: Round to integers?

Hi everyone,

I picked up a Daisy Patch last week and I’ve been having a lot of fun adapting the Gen~ example patches into the Oopsy template.

I have a question regarding params. Is it possible to lock param values to integers, so that the values display as integers on the “params” pages of the Daisy Patch screen? As of right now, the parameters in my patches default to 3 decimal places, and the values jump around a lot (especially if the min max range of the param is large). I am using a ceil object after the param object so the value rounds to the nearest integer beofre it is sent to the rest of the patch, but this seems to happen after the param value is sent to the screen, so the value displayed on the “params” page is not rounded to the nearest integer. Does anyone have any suggestions to remedy this?

Yes – this is implemented for the next update, or in the dev branch of Oopsy if you want to get it right now.

E.g. [param cv1_int_foo @min 0 @max 4] will only ever send 0, 1, 2, 3 or 4.

Also, [param cv2_bool_foo @min 2 @max 5] will only ever be 2 or 5, etc.

3 Likes

Oh, awesome :slight_smile: Thanks for the quick reply. And thanks for all that you are doing for Oopsy. Amazing work :pray:

Oh yeah! I’ve been wanting this and have been using the dev files but didn’t realize it was already there

Hey hey guys,

I have the exact same problem here. Wanned to learn my way into Gen (only normal max user here) and followed some tutorials from GREGORY TAYLOR back at cycling 74 forum. Works pretty nice with oopsy, but now I’m hanging at his ringig feedback delay, where I exaczly need to toggle between outputs of different gate objects in gen.

So yeah I wanned to ask if this integre function is already applied to oopsy or still in the dev branch and if it is still in the devbranch how do I get it integrated into my oopsy? I’m still a noob with github, didn’t clone the the oopsy daisy lib, but used you’re direct link, so excuse myself, how do I import something from zhe dev branch of github? Haha

Thanks in advance
Greetings Frank

Still in the dev branch currently.

Check out some of the other threads here, the question about how to get the dev branch working has been asked quite a few times :slight_smile:

Ok I got the dev branch and simply made a backup of the original releasy and names the dev branch simply to oopsy and it seems to work, because I see the new interface, but now when I want to compile I get this errormessage:

And this is where I wanned to try the integre number part. Did I do somethime wrong with naming the param? Feeder should be the name of the parameter on the oled. Before I took the dev branch everThing worked fine with compiling. So I guess I need to do some more then only download the zip of the dev branche and put it in the max 8 package foulder and name it oopsy?

Thanks in advance again haha
Greetings frank

Ah ok sorry. Then I will take a deeper look in the forum :slight_smile: I should have guessed I’m not the only one haha. Sorry for spamming this topic :wink:

“command failed: make” probably means you need to install the prerequistes for compiling for ARM. See the info on “setting up the toolchain” here: 1e. Getting Started With Oopsy (Gen~ Integration) · electro-smith/DaisyWiki Wiki · GitHub

1 Like

Oh yeah I did this, but it seemed a bit weird but never get my head around. I took you’re new windows toolchain tutorial 1c

It was linked in the 1e part you were sending. But yeha did that yesterday, extracted it like it said to my documents folder and run the install.bat. then a cmd console pops up but disappears one second later with no written code inside it. Thought myself it is weird but maybe it’s installing in the background. But I guess not?!

But yeah like I said with the normal branch it worked fine, the make error only first came with the dev branch.

Sorry I know you are not here to correct my mistakes haha but maybe there is an easy solution I don’t know. Otherwise, I go back to the normal brnache and wait for the next update. No problem at all, there is more to discover then integres in gen and oopsy haha

Thanks for your quick response! :slight_smile: