Oopsy sampler playback

HI all, I am attempting create a sampler with the Daisy patches of module, using Oopsyand Gen/Max MSP.
I’ve edited a patcher orignally made by Graham Wakefield in Gen~, so that it works as a sound on sound looper. I put it together in gen and it sounds great, no issues.

I’m attempting to make it into a eurorack module, and after getting the patch submodule on the breadboard, I’m having an issue where once I move knobs/ controls related to the phasor reading from the buffer, the sample play back becomes noisy and distored in a way it is not when in the gen patch- I know sometimes analog hardware noise can cause this, so I put the oopsy.ctl.smooth3 object infront of all the parameters and still get the same result.

Could someone with the patch/patch submodule assist in perhaps testing my max patcher on their unite to see if the issue persists? Any help as to why they would fundamentall;y work different in the atch vs embedded hardware would help. Attached is a link to the max patcher ready to be flashed to daisy patch. Thanks! troubleshootloop.maxpat - Google Drive


What I would recommend is isolating various sections of the patch and troubleshooting one section at a time. Scaling down helps!
For example, is there still a noise just from playing back an audio sample without any ADC input mapping?

Also, having a version without the CV out stuff will make it easier for other people to pinpoint the issue.
And commenting what each object/section is doing will help immensely :slight_smile:

Finally, please feel to share screenshot of the gen~ patch in addition to the download link.

I think the first step is to test if the sound on sound looper itself is working properly when flashed to the Patch SM. And then start building up one step at a time from there. Good luck and I would be happy to troubleshoot further with you!