Oopsy + custom json not working rev4

Hello, I have some difficult to make a simple potentiometer doing anything with a custom json in Oopsy.
Here is my json, my patch, and my wiring.
I can hear the cycle, but not affect the volume. It means my patch flashed correctly, but the json don’t make the pot working.

Things I want to precise :
• I am used to work with different platform for digital synth design, I’m used to code in different language, I design PCB, and I’m a daily user of max since years. so I more than double checked everything. :slight_smile:
• Yes I selected with browse my custom json
• Yes both of my code & patch are located in the same folder
• Yes I’m aware about the pin gpio-pin/physical-pin difference
• I did tried the bridge between the two GND of the seed
• I have a second board (also a rev4) and I did tried with it
• I don’t use a crack of max/gen~
• The pot is of course a b10k and I tried to replace it
• Oopsy is the latest version installed & max is version 8.5.2

So, I’m very lost now. I think I’ve spent time to read every thread about similar subject before posting here. So here is what can I suspect :
• Rev4 is not working with custom JSON ?
• I’m mistaking something in the name of my patch/json or gen~, like they have to be identical or so ?
• I have the whole digital world against me ?

By the way I ordered two rev7 today which should be there next week. I hope it will solve the problem. But if anyone can help or suggest something to try, I’ll be very happy :slight_smile:


I reply to myself just to say that I tried to wire the potentiometer the same way as the pod is, and flash my patch with the pod JSON file. But no success. So maybe it’s an Oopsy issue ? I’m using apple m1 2020 with os 11.4

Connect AGND to DGND?

I tried, this is what I was talking about when I was saying “bridge between the two gnd”. :frowning:

The hardware setup looks good, can you verify it with a simple C++ program?

Oh I didn’t even thought about that ! I will flash a C++ exemple it’s perfect to know if the issue is from Oopsy. Thanks for the tips. I’ll keep you in tune.

1 Like

Hello, just to report here that the issue is definitely from the rev4 board. I received two rev7 seed today, tested the exact same circuit and all worked immediately.
I tested this with two different rev4 boards and the issue was the same. I can’t tell where the issue is from but I hope the developers will see this thread because I’d love to use my two rev4 for some projects using Oopsy :slight_smile: