Noob close to Binking, still missing something

I know I have been a PITA to folks in my short time on the Forum. I apologize for being so obtuse in setting up my development environment, and then bitching about it.

I honestly think I am close to being able to play with code. As you can see below, I opened Blink in VSCode no problem. But doing the “task build_all” result is the error “/usr/bin/bash: make: command not found”.

So I guess I have directories and/or paths messed up. I think I followed the directions carefully, including installing cygwin and adding the path in the environment variables. This is pretty far into the weeds for an old hardware guy, so any constructive advice would be appreciated. Thanks in advance.

Hmm. I don’t know much about VS Code, but I might be able to help anyway.

Looking at the path, it’s trying to run bash from the Git directory. I suspect that’s not your cygwin bash. I know git-bash is a thing on windows that VS Code might reasonably interop with. Is it running git-bash instead of cygwin? But I’m not sure if that matters. I would think it’d still be able to find make in your path.

Can you run bash from the windows terminal? If you can, what does running which make in bash return?

It might be the case that even if it is in your path on windows, it’s not visible in the path from inside bash, which IIRC keeps it’s own environment variables. What do you get from running echo "$PATH" in bash? If you get a colon-separated list of directories, does it include the dir make is in?

Thanks sharps. Yes, the git bash that I have in the Select Default Shell dropdown is at:
C:\Program Files\git\bin\bash.exe.
I also have a bash application in:
which is the path I added in the Windows system environment variables after the cygwin install, per the directions.

When I do bash from Command prompt and the “which make” I get:
DONST@LAPTOP-J856ECA6 /cygdrive/c/Users/DONST
$ which make
which: no make in (/cygdrive/c/Program Files (x86)/Intel/iCLS Client:/cygdrive/c/Program Files/Intel/iCLS Client:/cygdrive/c/WINDOWS/system32:/cygdrive/c/WINDOWS:/cygdrive/c/WINDOWS/System32/Wbem:/cygdrive/c/WINDOWS/System32/WindowsPowerShell/v1.0:/cygdrive/c/Program Files (x86)/Intel/Intel(R) Management Engine Components/DAL:/cygdrive/c/Program Files/Intel/Intel(R) Management Engine Components/DAL:/cygdrive/c/Program Files (x86)/Intel/Intel(R) Management Engine Components/IPT:/cygdrive/c/Program Files/Intel/Intel(R) Management Engine Components/IPT:/cygdrive/c/Program Files (x86)/QuickTime/QTSystem:/cygdrive/c/WINDOWS/System32/OpenSSH:/cygdrive/c/Program Files/Git/cmd:/cygdrive/c/Program Files (x86)/GNU Arm Embedded Toolchain/10 2020-q4-major/bin:/cygdrive/c/Users/DONST/AppData/Local/Microsoft/WindowsApps:/usr/bin:/cygdrive/c/Users/DONST/AppData/Local/Programs/Microsoft VS Code/bin:/cygdrive/c/Users/DONST/Documents/dfu-util-0.10-binaries)

When I do ‘echo “$PATH”’ from the bash in the VSCode terminal I get this, which has no “make” in it:
/mingw64/bin:/usr/bin:/c/Users/DONST/bin:/c/Program Files (x86)/Intel/iCLS Client:/c/Program Files/Intel/iCLS Client:/c/WINDOWS/system32:/c/WINDOWS:/c/WINDOWS/System32/Wbem:/c/WINDOWS/System32/WindowsPowerShell/v1.0:/c/Program FileProgram Files (x86)/Intel/Intel(R) Management Engine Components/DAL:/c/Program Files/Intel/Intel(R) Management Engine Components/DAL:/c/Program (x86)/Intel Files (x86)/Intel/Intel(R) Management Engine Components/IPT:/c/Program Files/Intel/Intel(R) Management Engine Components/IPT:/c/Program Files ime/QTNDOWS/
(x86)/QuickTime/QTSystem:/c/WINDOWS/System32/OpenSSH:/cmd:/c/Program Files (x86)/GNU Arm Embedded Toolchain/10 2020-q4-major/bin:/c/Users/DONSTrosoftgwin64/AppData/Local/Microsoft/WindowsApps:/c/cygwin64/bin:/c/Users/DONST/AppData/Local/Programs/Microsoft VS Code/bin:/c/Users/DONST/Documents/dfu-util-0.10-binaries

Beyond the simple concept of files needing to be in the proper directories for things to work, this is pretty much Greek to me. I very much appreciate your help. Once I get up to speed I hope I can contribute to others on the forum. I am already trying to help with a couple of hardware questions.

This section of the install instructions is slightly in flux right now.
For now you can do this:

Install make for windows from here: The right installer is “Complete package, except sources”.
Open “Edit environment variables for your account”
Double click Path.
Click New.
Put in the path where make was installed. I think it’s C:\Program Files (x86)\GnuWin32\bin\
but don’t quote me on that.
If you relaunch git bash and try which make it should work.

Thank you, Ben. That got me through the “task build_all”. I then got on error on the “task build_and_program_dfu” until I corrected my path to the dfu-util-0.10-binaries\win32 folder. Now successfully Blinking! :slightly_smiling_face:

You might was to clarify that whole dfu_util.tar.xz extract and add path" part of the process, as it is pretty sketchy for us noobs.

1 Like

Glad you solved it. I was gonna suggest that you needed to install make through cygwin, and/or set your default shell to the cygwin one.

But it seems that a regular install of make worked :slight_smile:

The output of those commands looks scary, but it does have a kind of sense to it: it’s a colon-seperated (with these: : ) list of directories. The directories generally at the root of your C drive, which is /c/ in cygwin. When you run a command, every directory in that list is checked to see if it has a program file with the name of that command.