No DFU Capable Devices?! Linux

Hello Daisy World!
I got the seed in the mail yesterday! However after getting things set up via tutorials, wiki and forum troubleshooting I just cannot get the device to be recognized. Not through Vs Code, not in the web programmer. I am running Linux (System 76 Pangolin//Pop Os 21.10//AMD Ryzen 7) and nothing seems to fix the issue. I tried several cables and made sure that my usb port is in fact working properly.
I can’t get the Blink example flashed to the seed :pensive:.
Error I get:
dfu-util: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release!!!
dfu-util: No DFU capable USB device available
make: *** […/…/libDaisy/core/Makefile:289: program-dfu] Error 74
The terminal process “/usr/bin/bash ‘-c’, ‘make clean; make; make program-dfu’” terminated with exit code: 2.

One other suspicious looking bit in VS code under the terminal Output Tab <C/C++ Configuration Warnings>:
[4/10/2022, 7:41:41 PM] Unable to resolve configuration with compilerPath “/usr/local/bin/arm-none-eabi-g++”. Using “/home/pc84/Developer/gcc-arm-11.2-2022.02-x86_64-arm-none-eabi/bin/arm-none-eabi-gcc” instead.
[4/10/2022, 7:41:41 PM] Unable to resolve configuration with compilerPath “/usr/local/bin/arm-none-eabi-g++”. Using “/home/pc84/Developer/gcc-arm-11.2-2022.02-x86_64-arm-none-eabi/bin/arm-none-eabi-gcc” instead.

Once I get past this hump I’ll be on my way to making! Thank you!!! :space_invader:

There’s a known issue with using the WebProgrammer on Linux. There are some solutions discussed in this thread that might work on that front.

We’ll look into the toolchain stuff a bit and get back to you on that!

1 Like

That’s definitely a bit strange. I daily drive Ubuntu, so I’d expect similar issues and resolutions for a problem like this. Have you tried seeing if your seed shows up at all to your computer with a command like lsusb? If your seed is in DFU mode, you should see lsusb output a line like:

Bus 001 Device 048: ID 0483:df11 STMicroelectronics STM Device in DFU Mode
1 Like

Thanks @ben_serge, I’ll check into it a bit more on the web programmer side.

@Corvus_Prudens I ran lsusb and the device shows up exactly like you said it should. Now I’m even more confused lol----But at least it EXISTS! So that’s a +1—it’s a matter of figuring out why the commands don’t see it now. :man_shrugging:

Hm, in that case you might try manually adding a udev rule, although I think that presents as a different dfu-util error. Probably at least worth a shot, though.

Adding the udev rule has fixed the web programmer issue and my seed shows up! I will continue to see if perhaps re-installing VS Code helps with building there( still does not show up there) and report back if I’m successful. For anyone in the future I followed the ‘manually adding a udev rule’ link AND I had to add myself (user) to the ‘plugdev’ group as suggested. I then made sure to reboot for everything to take effect and the changes to be reflected. Thank you all so much for your quick and effective help! I can’t wait to explore this DIY hardware!!!
:sunflower: :sunflower: :sunflower: :floppy_disk: :floppy_disk: :floppy_disk: