No Audio output on Daisy pod

Hi, I have managed to successfully download a number of the example Arduino DaisyPod sketches to my Daisy Pod. When I press the buttons the LED’s respond, light up and behave exactly as you would expect but there is no audio coming out of he headphone socket at any volume. Not even a click when you plug in the phone jack or any background hiss - total silence.
My question is whether I am missing something obvious here or whether I have a faulty Daisy Pod board?

Which sketches have you tried uploading? I’d suggest SimpleOscillator as a good one.

Aside from that, I’d make sure your libraries are up to date. You can update DaisyDuino from
Tools > Manage Libraries, search for DaisyDuino and make sure it’s updated to the latest version.

Test that, and if it still doesn’t work try updating your boards via Tools > Board: > Boards Manager
search for STM32 and make sure you’re on the latest version (as of now that’s 2.2.0).

If neither work, you can validate your hardware via the web programmer with either the pod SimpleOscillator or the seed_DSP whitenoise

1 Like

I have tried updating my boards searching for STM32 in boards manager and it states that they are deprecated, last available version being 2.0.0 and that I am to use the new package index on main branch at
How do I use this on my main branch? I do not know what this phrase means and I have made numerous Arduino projects.

OK I worked that part out, you paste the link into Arduino, Files, paste into the box called: Additional Board Manager URLs:
The you open Tools, Board, Board Manager again and type in STM32
The opportunity to update it (to version 2.2.0) now appears, i.e. the UPDATE option appears, so you then click on it. The Boards Manager will then update the STM32 boards, be aware this does take a little while.

Sorry I wasn’t clear enough about that! They deprecated that link a while back, I’m glad you were able to work the process out for yourself. Is audio output working for you now?

1 Like