Need help with VS Code to flash and write to my daisy seed (SOLVED)


I’m new to C++ VS code etc. so if this is a silly question I apologize. After a while of forum searching, I finally thought I got the environment set up properly and I’m trying to get blink.cpp flashed onto the seed.

The seed is plugged into my laptop via USB, I’ve initiated the “bootloader mode” following the setup instructions but when I run the “task build_and_program_dfu” nothing on the daisy seed happens. VS code takes me to the tasks.json file and highlights the “build_and_program_dfu” section of the file.

I was able to use the web programmer just fine to load the blink app and other examples and they work. What am I doing wrong in VS code?

@elldawg Welcome to the forum! I think you’re reconfiguring the default task, rather than executing the task. Type Cmd + P, then type task build_and_program_dfu and hit enter.

Hi alo.bu,

I selected “task build_and_program_dfu” from this list and still nothing happens, takes me to that section of the .json file again.

I agree it seems like what I’m doing is prompting vscode to take me to the section of the .json file to edit it.

Doh, solved it.

As you said alo.bu, I was mistakingly using the command CMD + Shift + P, not CMD+P, and unwittingly selecting the “tasks: Configure default build task” then selecting the “build_and_program_dfu”

thanks for the help and clarification. the light is blinking!

1 Like