Make compilation terminated

hi everyone,

I have followed every step on README.MD successfully until i have trouble making .bin file for daisy

when i command MAKE on ~/pd2dsy/examples/pod_daisyTest_3-1/ i get this error:

arm-none-eabi-g++  -c -mcpu=cortex-m7 -mthumb -mfpu=fpv5-d16 -mfloat-abi=hard  -DUSE_HAL_DRIVER -DSTM32H750xx -DUSE_HAL_DRIVER -DHSE_VALUE=16000000 -DSTM32H750xx -Ic/ -I../../libdaisy -I../../libdaisy/src/ -I../../libdaisy/Drivers/CMSIS/Include/ -I../../libdaisy/Drivers/CMSIS/Device/ST/STM32H7xx/Include -I../../libdaisy/Drivers/STM32H7xx_HAL_Driver/Inc/ -I../../libdaisy/core/ -I  -O2 -Wall -Wno-missing-attributes -fasm -fdata-sections -ffunction-sections -MMD -MP -MF"build/Heavy_pod_daisyTest_3_1.d" -fno-exceptions -fasm -finline -finline-functions-called-once -fshort-enums -fno-move-loop-invariants -fno-unwind-tables  -std=gnu++14 -Wa,-a,-ad,-alms=build/Heavy_pod_daisyTest_3_1.lst c/Heavy_pod_daisyTest_3_1.cpp -o build/Heavy_pod_daisyTest_3_1.o
In file included from c/HeavyContextInterface.hpp:20,
                 from c/HeavyContext.hpp:20,
                 from c/Heavy_pod_daisyTest_3_1.hpp:37,
                 from c/Heavy_pod_daisyTest_3_1.cpp:33:
c/HvUtils.h:33:4: warning: #warning Could not detect platform. Assuming Unix-like. [-Wcpp]
   33 |   #warning Could not detect platform. Assuming Unix-like.
      |    ^~~~~~~
arm-none-eabi-g++  -c -mcpu=cortex-m7 -mthumb -mfpu=fpv5-d16 -mfloat-abi=hard  -DUSE_HAL_DRIVER -DSTM32H750xx -DUSE_HAL_DRIVER -DHSE_VALUE=16000000 -DSTM32H750xx -Ic/ -I../../libdaisy -I../../libdaisy/src/ -I../../libdaisy/Drivers/CMSIS/Include/ -I../../libdaisy/Drivers/CMSIS/Device/ST/STM32H7xx/Include -I../../libdaisy/Drivers/STM32H7xx_HAL_Driver/Inc/ -I../../libdaisy/core/ -I  -O2 -Wall -Wno-missing-attributes -fasm -fdata-sections -ffunction-sections -MMD -MP -MF"build/pod_daisyTest_3-1.d" -fno-exceptions -fasm -finline -finline-functions-called-once -fshort-enums -fno-move-loop-invariants -fno-unwind-tables  -std=gnu++14 -Wa,-a,-ad,-alms=build/pod_daisyTest_3-1.lst pod_daisyTest_3-1.cpp -o build/pod_daisyTest_3-1.o
pod_daisyTest_3-1.cpp:5:10: fatal error: c/Heavy_pod_daisyTest_3-1.hpp: No such file or directory
    5 | #include "c/Heavy_pod_daisyTest_3-1.hpp"
      |          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [../../libdaisy/core/Makefile:194: build/pod_daisyTest_3-1.o] Error 1

i tried make clean all , git pull origin master. everythings runs fine with no errors except make command for making .bin file

My setup is:

Ubuntu 20.04.02 LTS python is 2.7 , pip2 list is:
enum       0.4.4
Jinja2     2.7.3
MarkupSafe 1.1.1
pip        20.3.4
setuptools 44.1.1
wheel      0.36.2

What I’m missing? Your help is needed
thanks a lot.

There’s something going wrong with your minuses and underscores here:


c/Heavy_pod_daisyTest_3-1.hpp: No such file or directory

Is that something you included, or specified in the make file? Might just be a typo …


The pd file is pod_daisyTest_3-1.pd
.cpp file (from is pod_daisyTest_3-1.cpp
And I did not change aything in Makefile.

But you are right, when i changed pd file name to pod_daisyTest_3_1.pd and re-convert to .cpp then make .bin it worked without any error.

Anyone who have same error can change dashes to underscore.

Thanks a lot for your help.

1 Like

maybe the minus character is not allowed in a file name and the script changes it to an underscore? just a guess at this point, haven’t used pd with daisy yet.