MacOS dfu-util Compatibility and Flashing Problems

I recently picked up a Daisy seed, but I’m unable to flash anything to it as it is not detected as a connected DFU device in BOOT mode. I’m on MacOS Monterey 12.6.3. Based on some other threads, it seems like there may be an inherent compatibility issue with this version of MacOS and dfu-util, but it’s not 100% clear to me whether or not this is actually the case.

I’ve tried multiple cables with no luck. Here’s the precise error reported by dfu-util when attempting to flash:

dfu-util: Warning: Invalid DFU suffix signature
dfu-util: A valid DFU suffix will be required in a future dfu-util release
dfu-util: No DFU capable USB device available

The first two lines are normal, and can be ignored.
I’m using MacOS 12.6.3, and it works fine here. 2015 MacbookPro 13".

Are you sure you’ve pressed the buttons in the correct sequence? If you’re new to Daisy, maybe you don’t realize that this must be done each time you want to flash the Daisy using DFU? Have you tried using the Web Programmer in Chrome Browser?

Reports of problems flashing the Daisy aren’t super rare, but they’re usually user error.

I’m doing the following:

  1. Connect the Daisy Seed via USB.
  2. Hold down the Boot button.
  3. Press the Reset button.
  4. Let go of the Boot button.

After doing this, the User LED stops blinking, as described in the wiki, however the Daisy is not discovered by dfu-util on my machine, nor is it detected in the web programmer (in chrome v. 109.0.5414.119).

I’m on the 2016 Mac, same OS version. Thanks for confirming it works for you, that rules out dfu-util compatibility issues.

I have tried multiple cables. On the off chance all of them happen to not use USB data lines (though I’m pretty sure at least one does) I’ll try picking up a cable directly from electro-smith to see if that’s the cause. Otherwise, maybe this is a strange issue with my particular system configuration. I didn’t install the Daisy toolchain provided by electrosmith as I already have most of the binaries required, but maybe it’s worth trying that too.

Alright, weirdly enough, this is an issue with my Macbook model. It turns out the problem was the USB port I was using on my Mac. I’ve tried a different port (on the right of the laptop instead of the left) and suddenly the daisy shows up.

Anyone else that has this model: MacBook Pro (13-inch, 2016, Four Thunderbolt 3 Ports) – heads up!

Thanks @tele_player for confirming it wasn’t a dfu-util problem!