Linux system won't program daisy seed (SOLVED)

I normally use a linux system, so I would like to use it to get started with a new daisy seed I just received. Unfortunately, although lsusb shows the daisy seed, when I use dfu-util, I get the following message:

dfu-util: Cannot open DFU device 0483:df11

When I check using lsusb, I can see this listing:

Bus 001 Device 006: ID 0483:df11 STMicroelectronics STM Device in DFU Mode

In addition, the web programmer does not connect; the “Flash Blink!” and “Program” buttons are greyed out. The “Connect” button shows “DFU in FS Mode - Paired” and I try to connect using that listing, but the web programmer doesn’t show you whether there is a successful connection, so I don’t know if it is connecting. Probably not, since I can’t program anything!

Trying with arduino and VSCode yields the same problem, in that the utility does not connect to the daisy seed, so it cannot flash anything.

Meanwhile, using an ancient Windows laptop, I can successfully use the web programmer to flash various programs to the daisy seed. So it doesn’t seem that there is a problem with the daisy seed, or the cable. It must be a problem with my linux system. For the record, it is a System76 Pop!OS. I don’t want to use the windows laptop because it is old and faulty in other ways.

Anyone have any ideas about how to get my linux system to program the daisy seed?

Sigh, the power of posting. It works now that I added a permissions rule to /etc/udev/rules.d.

For the record, here is what I did:

(1) sudo vim /etc/udev/rules.d/50-Daisy.rules
(2) added this line:


with MYUSERNAME being … my user name.

(3) saved and closed that file and restarted my computer.

This assumes you know how to use vim. Use any text editor you like, but you will need sudo for it.

I use this rule myself:

dreamer@auditorium:~$ cat /etc/udev/rules.d/50-daisy-stmicro-dfu.rules 
SUBSYSTEMS=="usb", ATTRS{idVendor}=="0483", ATTRS{idProduct}=="df11", MODE="0666", GROUP="plugdev"

The plugdev is a common group to use for this kind of stuff (just have to make sure your user is in the group).

No need to restart the computer, you can just run udevadm control --reload-rules && udevadm trigger with sudo.