Linux Chrome: Cannot flash blink via web programmer. SOLVED

hi daisies,
the webprogrammer let’s me connect and says “paired”,
but the “flash blink” button is dimmed, so is the “program” button and i have no idea what to try next?!

any suggestions?

When you see the ‘paired’ message, click’connect.

that’s the only thing it let’s me do: click connect.
in the dialoge i select “dfu in fs mode - paired”.
then i click “connect” again.


You need to select the line that says paired, then click connect on that panel.

i do, i do, i do…

forgot to mention i’m on linux.
tried on a win10 machine in meantime and got it working!

maybe it’s a linux usb port permission issue?

1 Like

Possible, I suppose. Works fine on both my Macs.

Still possible, but the web programmer works fine on my MX-Linux Ver 19.4 with a Daisy Pod and Field connected by USB without a hub.

Perhaps you could try it on another machine? Either Linux or different OS. That would give us more info, and if it works would mean your Daisy hardware is good.

What are you trying to program (Seed, Pod, Petal, Field, etc)?

i already tried on a win10 machine and everything worked as expected.
it also works from my android tablet!
so the daisy (daisy pod) seems ok. also the usb cable and usb port.

on the linux machine, i use arduino ide to program arduinos via usb without any problems at all.

i tried dfu-util and found it needs sudo to work.
therefor my idea that it is a permission thing.

added user to groups tty and dialout.
had to restart.
now the webprogrammer is working on my linux machine.

thanks @tele_player and @tunagenes for your help!