Hey everyone, just wanted to put a heads up that I’ll be working on unifying the API between the breakout boards over the next few days. This started in the last update with the Audio functions, which are now common across all platforms (with the exception of interleaving audio on the patch).
Currently there are a lot of different function names for the same few things across the breakout boards. For example,
UpdateDigitalControls on the field, does the same as
DebounceControls on the patch, and so on. Same goes for handling Analog controls, getting control values, etc.
This will break some programs, requiring a rename of the affected function names in your own projects, but unifying these function names to a shared set will go a long way in making it easier to migrate projects from one platform to another, add support for more breakout boards, and simplify integrations that rely on code generation (pd, etc.)
If anyone has any opinions, feel free to let me know! For now, I’m planning on having an
UpdateDigitalControls in place of the several other variants.