Issue with Getting Leds to work on Button Press -PD2DSY

I am attempting to get button presses to light up the Led.
I found this sketch which works correctly for all audio but it does not light up the LEDS

I see in the Notes on the WIKI that we should be able to use LEDS with these names for the pod

RGB LED led2_red, led2_green, led2_blue, led2_white

and for the buttons i see these names
Switch sw1_press, sw2_fall, sw2_seconds

so in this case i have tried to connect the button to the led

the rest of the PD file works on the POD but when i push the buttons I do not get any LED lighting up

Thanks for your help

Hey Dan!

The podtest.pd in our example folder looks sliiightly different. I’ll attach it here and see if it changes anything. It’s the same alias for the buttons, so I can’t imagine it’ll make a difference, but just in case.

Another different factor is that you’re flashing this in PlugData. Was this an issue when you were flashing the vanilla patcher via terminal? I remember that you used to flash via that method before, so I recommend trying this patcher with that.

ok using the POD TEST file you sent me
the LEDs never light up on the pod_test PD. if they light up for you on your pod when you run that pd file then

  1. the version of my lib is different ?
  2. my board has issues with the LEDS
  3. some other unknown issue


Did you load and run the web programmer Pod examples? If the buttons and LEDs work in those examples, it is extremely unlikely that there is something about your Pod that won’t let Pd illuminate an LED.

no none of the examples light up my LED in response to a button

only the buttons but none of the PD sketches I have tested will light up the LEDS on my Pod

i should explain more clearly—in the case of pod_test.PD it appears the buttons should trigger the LED when you push a button. the button does trigger a sound HOWEVER the leds never turn on with this PD sketch or any other. HOWEVER each time i reboot (ANY) PD2DSY program on my pod the audio makes a loud POP and one of the leds flashes VERY VERY brightly in White.

and that is from the example library

Hey Dan,

I recommend trying out different languages to test/confirm if it’s something funky with the hardware itself.

DaisyDuino is easy to set up and there should be less factors that will end up being different between our setups. I re-set it up 2 weeks ago to make a tutorial, and I just now tried the SimpleButton program that comes in the DaisyDuino library to confirm that it does work on my Pod.

This setup video tutorial by Roey is quick and great.

I’m sorry that I can’t test with you using PlugData as it’s incompatible with my OS (MacOS 10.14). I’m thinking about updating it after I finish editing a video.

If the LED does work with DaisyDuino, then what I would probably recommend is getting the terminal method to work. Once it’s set up, it’s honestly fine to use.

Finally, I’m curious to know if the LEDs never worked once when you flashed a Pure Data program like pod_test.pd.
Also, did the “led flashing very brightly in white”-thing always happened or did it start happening after flashing a certain program? There’s a situation similar to that happening to one of the users in Discord. Thanks.

the white flashing happened from the first time i ever used PD2DSY in the terminal. you mentioned another user had this issue so maybe i will look on discord for that thread.

I have now tried in the terminal PD2DSY and it still does not light up so I do not think it is a Plugdata issue at all.

i guess for now I will maybe forgot about the pod and just use PD2DSY with the patch.


Actually, you can use plugdata to program Daisy on older Mac OS. Instead of having plugdata compile and upload to Daisy, just have plugdata create the code. Then use terminal to run make from the command line.

Hey Dan,

I just wanted to confirm if it wasn’t an issue with PlugData. Thank you for confirming!

If you could confirm that it’s still an issue with other dev environments, like DaisyDuino for example, let me know.

And yes, please do join the Discord and feel free to ping them in the “troubleshooting” channel.

I’d expect that cricketbee is is the same person that already described this problem on Discord.

There was a user on Discord who, after flashing a certain program, started observing their patch.Init() acting up. So I wanted to confirm with cricketbee if the bright white LED thing was a result of flashing a certain program too. It doesn’t seem like it though.

I just wanted to ask as much details as possible :man_bowing: