Issue getting LED to work with GPIO Pin

Probably quite a simple question but I’m stuck and haven’t found the answer after rumaging all over the forum for the last hour :slight_smile:

I have a custom Seed build in which one LED is connected to GPIO24 (DAC OUT 1) and another on a regular pin GPIO 29.

Initially I couldn’t get either LED to work while using the “Led” components in my custom JSON file. After changing the first LED to CVOuts (since it’s on pin 24 which is the CV DAC) I can get that one working, but I can’t do the same for the LED on GPIO29.

I’m sure I’ve overlooked something very basic in order for the custom seed to consider that GPIO pin as an output but I’m stuck, any help would be appreciated!

Screenshot 2023-07-05 at 14.55.37

@PlasticLobster ,

Do you have the GPIO mode set to output so you can drive the LED?

Another thing to consider is that you may need to use a square wave for the GPIO out so that it is on/off and then ensure it is pulsing fast enough / or on long enough that the LED will light.

(I added some more details for you, I hope this helps)

  1. The CVout will convert the 0 to 1 in the cycle to 0 to 3.3V (max V out) on the output of the seed. This will drive the LED just fine and the LED will look like it is pulsing.
  2. When you use a GPIO out it is either on or off. The seed will take the cycle from 0-1 and covert that to on and off (0V out to max/3.3V out). What I don’t know is when does the 0-1 of the cycle cause the GPIO to turn on / make the Vout of the pin to be at its Vout Max…
  3. Given that a GPIO is either on or off causing the V out to be 0V or Max (3.3V) then a user needs to use a pulse width to modulate the brightness of the LED. To do this you have a square wave that you can set pulse width. The pulse width and frequency set how bright the LED is by turning the LED on/off for more or less time making it feel brighter or darker.

Hopefully that will help… I have not used Max in a while.


Hi PlasticLobster!

I recreated the JSON file and patch that you put together and both LEDs are working (I used 0.5 hertz but I don’t think that makes too much of a difference).

This leads me to think that there could be something with your electronics instead. Please double check that one of your LED is connected to pin D29. Also, swap the LEDs to make sure the LED itself is fine. And etc.

Keep me posted :slight_smile:

Hi Takumi and Brett!

I’ve been an idiot: the Daisy Seed component that I imported into DipTrace from your EAGLE Library (a while back) shows GPIO pins starting at 1 and not 0, so there is an offset of 1 with the digital blue “Daisy Pin Names”. I built my custom JSON using my DipTrace schematic as a reference… Several of the pins were consequently off by 1, once corrected things are now working as expected! Thanks.

Quick extra question: I think I read somewhere that the LED “polarity” (1=ON, 0=OFF or vice-versa) can be configured in the JSON file, could you remind me of the way to do so?


Glad to hear that it’s working now!

Are you referring to this?

Yes that must be it! I’ll wait a little before beta testing the new Oopsy but I’ll keep that in mind, thanks :slight_smile: