Flashing Terrarium using PlugData

Hi guys, just finished my Terrarium build and have been enjoying it so far. I’ve been able to load bin files via the web programmer but I am having trouble with PlugData. I am hoping to load this patch, so far I have been able to get PlugData to say it’s successfully exported with the compiler, but I have no LEDs and no sound.

I have followed the OP’s instructions “If you built the stock Terrarium pedal then follow the instructions he wrote in the description of this video to remove the clock-related pieces from the module. Then remove the clock settings from the terrarium_clockmod.json file that he included in the fileshare.To get the program onto your pedal, use PlugData’s Compile feature and follow the compile settings he described in my comment thread. Select “Target Board : Custom” and load your modified terrarium_clockmod.json file. Select “Custom Linker:” and find the sram_linker_sdram.ldf file (it may be in a different directory than the etc directory), then select “App Type:” SRAM.” so that is how my export settings are currently set up.

Although it says that export was successful it also shows this message at the end of the dialog:

Warning: Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
No DFU capable USB device available
make: *** […/…/libdaisy/core/Makefile:330: program-dfu] Error 74

I’m thinking this is the root of the issue but I have no clue how to fix it. Any help would be greatly appreciated!

The SRAM type requires to have the bootloader. Plugdata should try to install the bootloader if it can’t find it, but this method isn’t 100% guaranteed.

Do you see the compiler flash two times?
It should do one for the bootloader, then another for the actual program.

The first time you have to put the device into flash mode: press and hold boot button, click reset button, let go of boot button. Now flash the program.
Once you have the bootloader installed: click reset button, see fading LED, click boot button, led keeps fading in/out as the bootloader is waiting. Now flash sram or qspi program types.

If you are unable to get the bootloader installed go to Daisy Web Programmer and under [Advanced...] select [Flash Bootloader Image].

Hey Dreamer thanks for the reply. I’ve tried both ways, having it auto detect and installing via the web programmer and it the same issue. Also tried sram, qpsi, huge etc without success. Any other ideas?

Can you confirm that you have the bootloader installed?

If you click reset do you see the on-board LED fading in/out?
If you then press the boot button does it keep fading?

Ok so interestingly when I click reset the LED briefly starts fading in and out and the USB connect sound plays on my PC but it quickly stops flashing and the disconnect sound plays. It’s the same when I initally plug the seed into my PC

While it fades click the boot button, does it keep fading?

Ya I’ve got it continuously fading now

Just got it working! I guess the trick was to get that LED flashing. Thanks so much for the help

1 Like