Failed Oopsy Build -- Error 2: make not found


Error 1:
I have the following issues:
oopsy-verbose: Could Not Find C:\Users<user>\Documents\Max 8\Packages\oopsy\source\build_TestRun01_field\build

The directory:
C:\Users<user>\Documents\Max 8\Packages\oopsy\source\build_TestRun01_field\
Is there, but the sub directory “build” is not.

Error 2:
oopsy-verbose: ‘make’ is not recognized as an internal or external command,

Although the tools are installed, any thoughts on how I might be able to ensure that the build directory could be found?

Any thoughts or help here would be appreciated.


Hi @BHAudio

It looks like both of your errors are related. The make tool is what generates the bulid/ folder and it’s contents.

To confirm that you have the tools installed correctly are you able to run make from the generated folder C:\Users\you\Documents\Max 8\Packages\oopsy\source\build_TestRun01_field\

that should raise any other related issues, or create the build folder and it’s contents. If that succeeds you can download the program to your daisy using the make program-dfu command, or use the Web Programmer.

If the above works, then I’d need to know a bit about which Make you installed.
It’s worth mentioning that in order for oopsy to run make it needs to be registered into the PATH for all shells to use. This is not always the case depending on where/how you installed make.

We are aware of the finicky nature of having to install everything on windows, and are working on a few things to greatly simplify this moving forward!


Thank you for the info.
As for the make - well, that could be interesting because I do have Visual Studio installed, but I’m not sure how that may (or may not) interfere with this.

As to what Make I installed:
I just did the Win32 installer, I checked the checkbox to “add to path” as noted in the install instructions.

If you wish to have me try the install again and/or add something to the path variable(s) I’m happy to give that a try.

If you can advise on what to try next, I’m all in for trying it out as I have some code I’d love to try running on my Daisy Field. :slight_smile:


Sorry, I may not have been clear. You should try running:


in your git-bash terminal from the oopsy\source\build_TestRun01_field directory.

Depending on how you installed git-bash, you should be able to right click in the folder, and click “Git Bash Here”.

Your Visual Studio installation will not interfere with this at all.

This should output a long sequence of text ending with something like:

arm-none-eabi-size build/fieldfoo6.elf
   text    data     bss     dec     hex filename
  70852     868 67135396        67207116        4017fcc build/fieldfoo6.elf
arm-none-eabi-objcopy -O ihex build/fieldfoo6.elf build/fieldfoo6.hex
arm-none-eabi-objcopy -O binary -S build/fieldfoo6.elf build/fieldfoo6.bin

Where fieldfoo6 will likely be TestRun01 in your case.

If, instead it outputs any errors, like:

bash: make: command not found

then that will confirm what the issue is and help us to get you up and running ASAP.

Hope that helps, let me know how that goes.


Sorry for my confusion.
I was able to do the “Git bash here”

When I go to run “make” I get:
“bash: make: file not found.”

Given this, clearly I am missing a path. :slight_smile:
How do i set the path so that bash can find the correct tools?

Thank you for your help, this is greatly appreciated.

No problem at all!

Some of this stuff is a bit of a bear on windows. We are actively working on simplifying the install process.

That does confirm that when you installed Make it did not properly add it to the PATH variable.

In order to fix this you should be able to follow the tutorial here.

In short, you will open your User Envirornment variables, and “Edit” the one named “Path”. Once you have that UI open you can hit “New” then “Browse” and select the location of the bin folder that you installed Make into. This is likely somewhere like: C:\Program Files\GnuWin32\make\bin or similar. You can search outside of this dialog for the file called, “make.exe”, and add the folder containing it to your Path variable.

To confirm this worked you should be able to open a new git-bash terminal and run, make and you should see:

$ make
make: *** No targets specified and no makefile found.  Stop.

If this doesn’t work, or is confusing let me know. We should actually have a simpler method of getting everything installed ready to go within the next few days to a week (downloading one folder, and double-clicking a file that will add stuff to the PATH variable for the user).

Hi, @shensley,

I wanted to let you know that I did a reinstall of the toolchain.
Here is the odd fact I noticed after my CYGWIN package reinstall.
In the C:\cygwin64\bin directory I do not have “Make.exe” in here.
I have a “make-dummy-cert” but no make.exe.

Did I do something incorrect with my CYGWIN install?

Thank you for all of your help thus far.
I am hopeful that I can get this going soon.

Thanks again for your help,

Oh, I see. I just followed along with the same thing, and can confirm that it is missing Make. So you did not do anything wrong. I believe this was a recent change to the wiki.

This was the original link to install Make (GnuWin32). It does have the limitation that it doesn’t play well with the normal command prompt, but if you use git bash it should work. To install there is the setup link that has a full installer.

I’m hoping that within the next week or so we’ll have a distributable version of the toolchain that will greatly reduce the complexity of the installation on windows (the version of make we’re testing there does not have the same limitation and should work fine in any terminal on windows), but this should get you up and running for now.


Good news!
Progress - yes!

I ran the GNU installer as you suggested.
I also added the path to the main directory and the bin directory.

I then went to the Oopsy package in my Max 8 directory.
Went to my test project.
Opened a GIT Bash shell.
Ran make.

… and …
This feels like great progress. :slight_smile:

I am looking forward to trying out my code on real hardware later today. ! (yeah!)
Very cool stuff!

I’ll confirm with this thread that I was able to get the code running on the hardware as soon as I get this going.

Thanks again for the help thus far!

Fantastic! Glad this got you up and running.

That output does confirm that the project is built. To confirm that you can load firmware to the device you can run make program-dfu from that same directory in the same terminal.

That said, at this point, you should be able to save and program the board directly from oopsy.

We’ll make a general announcement when the new toolchain is in place, and the wiki is fixed, but for now you should be good to go :slight_smile:


Yup - I fired up Max 8 just a moment ago and was able to load the file down to the hardware! yeah!

Super, super excited to get this going!!!

Thank you for all of the help!