Encoder not working with Oopsy Pod template patch

Hi I’m trying to get my encoder to work with Oopsy, but no succes so far.

I am using the oopsy_pod.maxpat from the oopsy templates folder: https://github.com/electro-smith/oopsy/blob/main/templates/oopsy_pod.maxpat

Here is a picture of my breadboard setup. Encoder is located up left:

I am using an ALPS EC12 series encoder.

So according to the Pod gen~ patch, turning the encoder should change the saw/triangle waveform. This does not happen.

I also watched the encoder output with an oscilloscope. Both terminal A and B are giving pulses (negative pulses). So I am assuming the hardware is OK.

Anybody got any idea?

What does work is:

  • potentiometer to change oscillator tune.
  • pushbutton to select between sine-rect-tri/saw
  • led output
  • audio output


Hello Jason!

Give this patch a try to confirm that your encoder is working with the Daisy.

Screenshot 2024-04-10 at 8.33.48 AM

Twisting the encoder will increase (or decrease depending on the direction) the frequency of an oscillator. You can select “pod” as the board. Just FYI, it’s 1 hertz per twist in this patch so keep on twisting to hear the change :smiley:

Should that middle pin of the encoder go to ground? Looks like pin 19 from the photo (although hard to tell).

Yes it’s going to ground.

Thx Takumi.

I just tried it out. I uploading it with pod as the board. I am hearing the 440 Hz sine wave, but turning the encoder doesn’t cause a change.

My apologies - zooming it makes it clearer. I’m really new to gen~ but when I open that template patch I can’t see that the encoder is actually connected to anything:

But then on adding Takumi’s suggestion to that patch, the encoder does work.

Ah, I realized I got the one from the dev branch: oopsy/templates/oopsy_pod.maxpat at dev · electro-smith/oopsy · GitHub
This is my pod template patch from the dev branch:

1 Like

Apologies again for being so unhelpful! I just tried this dev patch on my pod, and the encoder only makes a change once I have pressed one of the buttons. Don’t have time to dig into the patch and learn why right now, but hopefully this is of some help at last?! :slight_smile:

Haha, no worries!
Yup when pressing a button, it switches to triangle/saw which has a morphing waveform that is influenced by the encoder.

Maybe there’s a bug in the oopsy package from the dev branch that I got installed? I could try to reinstall the oopsy package with the one from the master branch, tomorrow.

1 Like

Ah I see, I think I remember the encoder not working on the dev branch.
I’m currently using the current/public release and I can confirm that encoder does work.


I downloaded the main branch, and the encoder is working now! Thanks!

1 Like

Glad to hear it!
And we’ll address the encoder issue for the new version of Oopsy when we get a chance to come back to it.

Unfortunately when using the main branch I’m now getting a compilation error when using GateOut in the custom json file. However, GateOut does work in the dev branch.

Somewhere in the oopsy verbos output it says: oopsy-verbose: “error: ‘dsy_gpio’ in namespace ‘daisy’ does not name a type”

I can make a new forum post about the GateOut if that’s better.

Also, do you have any indication on when a new version of Oopsy is coming?