Dev Environment setup on Windows 10 - Error running

I’m currently setting up my dev environment on a Windows 10 machine by going through the steps listed under “1. Setting Up Your Development Environment” in the DaisyWiki. However, I’m having an issue at the step titled “3. Build the Libraries”. When I try to run, I get the following output:2021-01-29 03_10_54-Window

Does anyone know how to resolve this particular issue?

OK so it looks like cd is freaking out with your path name due to the space.
The simple fix for now is for you to manually just cd into libdaisy and daisysp one at a time and run make.

So that’s something like
cd "Google Drive/diy/2021-projects/git-hole/DaisyExamples/DaisySP"
cd ../libdaisy

I’ll look into a more permanent solution to push to DaisyExamples as well.

Update: There’s already a bug report on github for this exact issue! Electro-smith is on the case. :+1:


That worked, thanks! Although for what it’s worth, I also tried running with the clone directory located at ~/Desktop/DaisyExamples (i.e. where it is in the wiki instructions) since that doesn’t have a space in path name, and it gave me exactly the same issue with cd as I had in the directory in ~/Google Drive/…

Huh that’s really weird…
What’s your home directory? You can run

cd ~

to find out.

It’s /c/Users/ashgr. I have another question if you don’t mind. When I try to flash the Blink program onto my unit (I’m using the Pod), I get this error: 2021-01-29 16_10_35-Window

2021-01-29 16_14_58-Dev Environment setup on Windows 10 - Error running - Troubleshoo

I’ve searched my computer and can’t find this .dll anywhere. I downloaded dfu-util from the link in the wiki, extracted it from the .tar.xz, and added it to the environmental path list, so I’m not sure what else I can do with it.

Do you have gcc installed? It comes as a part of the arm toolchain.
You’ll want to add that to your system path as well.

Yes, and I checked the option to add it to the environmental path during the install

OK I suspect this is the problem. You want to use the win64 version of dfu-util. So leave that environment variable alone and delete the other two.

I was having a hard time recreating the error because my system actually had that dll hanging around from an old install of GTK or something. Once I got rid of that the 32 bit dfu-util broke but the 64 bit one was OK.

1 Like

I just tried that, and it flash successfully. Thanks! I wasn’t sure which it wanted since the ARM Toolchain program is 32-bit, so that’s why I had both in there.

1 Like

Heck yeah! Glad to hear it.

1 Like

Hello Ben!

Sorry I’m a little late to the party, but I’m having a similar problem.

  1. When I run, this dialogue box flashes for a second and quickly disappears. I decided to try your alternate solution (see #2)error

  2. Upon trying to run the make files individually, I get an error. When executing “make” with DaisySP, everything runs fine. However, with libdaisy, I get the following error:

mkdir -p build/Drivers/STM32H7xx_HAL_Driver/Src
The syntax of the command is incorrect.
make: *** [build/Drivers/STM32H7xx_HAL_Driver/Src/stm32h7xx_hal.o] Error 1

Thanks in Advance!

Seems like a problem with path names in both cases.
I suspect it’s something with forward vs back slashes.

Which version of git bash are you on? Mine builds fine on the latest version. You can upgrade with git update-git-for-windows

1 Like

I’m using the latest version of git bash
That’s what I initially thought, but when comparing to the previous post above, mine seemed correct. Regardless, here’s a screenshot of my Paths


Not the PATH variable, but rather the filepaths. e.g. /c/Users/... in the first command, and build/Drivers/... in the second.

Could you try running something like
mkdir -p "test1/test1"
or perhaps
mkdir -p test2\\test2

Those should work, and mkdir -p test3/test3 should fail if my diagnosis is sound.