Daisy seed not showing on serial monitor

Hello guys, I am having issues with daisy seed not appearing in port selection for serial monitor. This has problem is both for Arduino IDE and Visual Studio Code. I am on windows 10, and have previously been able to find the port.

I have reinstalled drivers using Zadig which has not helped.

Here are screen shots of VSC:

Arduino IDE:


It might be that Windows no longer recognises the Daisy as a usb serial device. When you look under ‘Devices’ in the Windows control panel, is the Daisy there?

I have looked and its not coming up as a device but it us as unspecified.


If you right-click and select properties, has it been assigned a com port number? Maybe post a screen shot.


Could you post a screenshot after clicking on that ‘Properties’ button? It should bring up a list which includes which COM port the device has been assigned

What does your code look like in Arduino IDE?

Hello Takumi,

The code used is from this video of yours: How to Connect a Potentiometer to the Daisy (DaisyDuino) (youtube.com)
A week ago this examples was working.

I have just tried the example again.

Daisy Seed setting:

Task Uploaded:

Serial Monitor:

After “uploading” that Arduino code and with the Daisy Seed still plugged in, what is shown on your Zadig?

By the way, here’s a thread where it sounds like a similar issue was being encountered and the community member was able to eventually get it working here. It may be a different thing, but I figured I should share at least.

the thing described in the thread linked above worked for me (i used to have this problem too until 5 minutes ago). i changed the drivers between winusb and usb cdc until i got it working lmao

1 Like

After Uploading the code this is what Zadig looks like:

Here is the code and error

I have tried reinstalling USB serial (CDC) it with creating a port 10 but then uploading this gets me an error again… Really getting frustrated :sweat_smile:.

try setting drivers for bootloader mode and normal serial mode separately.

This is the driver for the daisy seed in bootloader mode:

And this is in serial mode (aka when running the program)

this worked for me like an hour ago and still works.

I’m so glad to hear that it’s working for you, @dvdtsb!! I know you were troubleshooting this for a while now.
And thank you so much for helping out too with your latest post.


Such an odd work around but running the example and replacing the drivers lets me access the serial monitor on a new port. Many thanks.

1 Like