Daisy Seed COM port not visible in Arduino IDE

Hi,
I have followed both the Web Programmer and the Arduino starting guide on github. I am using Windows 10.
Programming the Daisy Seed with the web programmer works, so I guess it is not a USB connection issue. But when using the Arduino IDE I can’t see the COM port on which the Daisy is connected. It was visible 2 days ago, but after going through the web programming install guide, the COM port didn’t appear anymore in the Arduino IDE. I also tried the BOOT/RESET knob sequence.

Here is a screenshot:


The COM port 3 is a printer port and not the Daisy Seed.

Cheers,
Jason

Hey @Jason

The Daisy will only show up as a COM port if the program running on it is using the serial library.

For programming via USB from arduino you’ll need to make sure the DFU Upload Method is selected, and then you can program it with the upload button while the Daisy is in the bootloader mode.

Hi Shensley,

Thanks alot! It’s as you describe.
I now understand that I don’t need to search for a COM port for uploading.

The uploading worked after a few tries with the method you and the starter guide described. The program works! Thx.

Cheers

I’m having a similar issue on MacOS. I’m able to program my Daisy Seed with the web programmer but it is not appearing on my port list in the Arduino IDE.

Would anyone have ideas of things I can check next? I tried updating my MacOS to Big Sur and the IDE to the latest version.

Thank you!

I followed this flow to set up my environment:

After two days I finally got it to work! Note that I was able to see the Seed in my MacOS system report as “DFU in FS Mode” and able to upload programs to it using the Web Programmer. It was just not appearing as a Port in my Arduino IDE. I have been able to get the Arduino IDE to work in the past. So this is a new problem.

I tried all the tricks on the internet.
-Confirm USB cable handles data
-Update MacOS and Arduino IDE
-Out of desperation, re-download FTDI helper package (I’m pretty sure Seed doesn’t use FTDI)
-Reset MacBook PRAM (something to do with the USB ports)

Finally, I remembered that last time I got this to work I was using an Apple USB C → HDMI + USB A + USB C dongle. This time I was using a simple USB C → USB A dongle. In some forum threads I saw people discussing Arduino IDE having trouble with USB 3.0 and being more compatible with USB 2.0.

So I double checked the system report and my new USB dongle was appearing as a “USB 3.0 hub”. I am traveling so I didn’t have access to my HDMI dongle, but borrowed one from a family member. Sure enough, this showed up as a USB 2.0 hub in the system report, and it appeared as a port in my arduino IDE!

Long story short, if your Daisy Seed is not showing up as a port in your Arduino IDE, one of many things you can check is that you’re using a USB 2.0 hub instead of a USB 3.0 hub. Thanks!