Daisy Patch - upload patch - troubleshooting

I just got the Daisy Patch
and am trying to upload one of the default patches available via https://electro-smith.github.io/Programmer/
I am on linux and am using a recent version Chrome browser.

I enter system bootloader with boot/enter.
I can connect to the Daisy Patch, selecting “DFU in FS mode” ( sometimes it is called “DFU in FS mode - paired” )

But then Program button never becomes active, so remains unclickable.

Home · electro-smith/DaisyWiki Wiki · GitHub mentions flashing of USER led,
I don’t see any change of this led.

Someone knows how I can troobleshoot this issue ?

I swear I saw a Youtube movie a few days ago showing how to upload a patch, but can’t seem to find it now.

Anybody ideas ?


I found the youtube movie: PAW 2020 • Livestream Andrew Ikenberry - Electrosmith - YouTube

I do as shown there, but for me the Program button remains disabled.

Hi @juaper, I can look into this a bit and get back to you.

For now, could you do two things that would help me narrow down the issue?

  1. Is there any hidden text in the space above the “Daisy Web Programmer” box (if you highlight over everything or ctrl-A it should highlight everything). Sometimes there are warnings that get marked there instead of inside the box…
  2. If you bring up the console in chrome (ctrl-F12). Are there any errors or warnings after “Page Created” or “Mounted Page”?
  3. Also, which distro of Linux are you using?

Thanks in advance!

Thanks for your answer @shensley

Ctrl-A made an error visible, “SecurityError: Access denied”
Web Programmer, "SecurityError: Access denied" on Linux (SOLVED) fixed it

1 Like