Daisy not showing up as connected

Hello, I just got a daisy seed and a daisy seed/pod combo for my pop and I to work with, and I’m having trouble with an initial connection. I have a Mac book pro, and he has a PC that he mainly uses Linux on. When trying to set up the daisy on either computer, it powers on when plugged into the usb jack, but when I look for it in the disk directory it’s not there; it’s as if nothing is plugged in. When I go to connect to the webdeveloper it isn’t listed there either. I know windows needs a usb driver reset, but is there something I’m supposed to do on Mac/Linux? Any help would be appreciated.
Thanks so much

On windows, you may have to update the driver to WinUSB. To do this, you can download the free software, Zadig. Instructions for this can be found on the DaisyWiki in the Windows toolchain instructions page. That’s from Daisy Web Programmer

Thanks, if I decide to use windows I’ll try that. my main OS are Mac and Linux. I only have windows installed on the PC, but it rarely gets used. The device isn’t showing up when it’s plugged in on either the MacBook or in Linux, and I can’t figure out why.

On the Mac, Daisy doesn’t show up as a disk device.
Use ‘About This Mac->System Report’ to see if the Daisy is listed under USB. Also note, it will report differently when put in DFU mode, by pressing both buttons.

I expect you’ll see it there. If not, maybe try another USB cable.

If it does appear, then try using Chrome browser to access it with the Web Programmer.

thanks so much for getting back to me.

I tried exactly what you said, and still no luck. i used 3 different usb A to microusb cable with both the seed and the seed/pod combo, and while they all receive power and the LEDs respond, they don’t show up when i go to the System Report. nor do they show up as an option to connect to in the web programmer in google chrome under either the linux or mac computer. I’m beginning to think i might have faulty units, but it seems very suspect to me that they’d both power on fine and neither of them would connect, which makes me think i must be doing something wrong.

did you press both buttons to switch to DFU mode?
Note: on the Pod, use the micro-USB on the Seed, the other one is for something else.

Yes, I pushed both buttons to enter that mode. The only things listed under usb on system report are the keyboard and track pad from the laptop. It’s the same when I try to connect with the web programmer; it’s not listed to connect to, either in boot mode or before I put it in boot mode. I can tell it’s going into boot mode because when I press both buttons the LEDs that are lit change. On I also downloaded the tool chain and tried updating the firmware and it can’t find the seed. At this point I’m not totally sure what to do. I emailed tech support; maybe they’ll have some ideas too.

I really appreciate you taking time to try to help me with this, it’s very kind.daniel

Interesting. I’m using a 2015 MacBook Pro, Mac OS 10.14.6, and keyboard/trackpad are on SPI.

Do you have any other USB devices to try, to verify the port and cable?

On my older 2009 MacBook Pro on El Capitan 10.11.6, Daisy only appears in the USB list when in DFU mode. Web Programmer works correctly.

Yea I’ve verified the port and cable with other devices. I’m running a 2013 MacBook Pro with Catalina. I just upgraded to Big Sur to see if by some chance that works.

What’s really confusing me is I have the same issue when I try to run the daisies on my dads Linux pc as well. I’d think it was the daisy for sure, except I also have a Cypress PSOC dev board that is doing the same thing (powering on when plugged in but not showing up as hardware) on both computers as well.

Ok so updating to big sur did the trick on the Mac for some reason! I’ll try it on Linux when I get home. Looks like mine works like your old Mac when it only shows up in DFU mode. Thanks for your help!!

1 Like

And for Linux follow the instructions here:

I develop on Debian 10 w/o problems using make and make program-dfu.

1 Like