"build_all" (and others) not showing up in VS Code

Hello everyone, hopefully this is a simple fix (I’m horrible with git/builds/etc.):

After following the various guides to getting my Terrarium DaisyDSP pedal set up, I am struggling with uploading newly created files to the seed. In my current state, I can use the Web Programmer Tool to upload original ‘petal’ effects, as well as some binary files (and the respective other files in the folder) that I found online.
Right now, I’m struggling with the task build_all stuff. I don’t see in in VSCode. I notice that tasks.json only has an echo task, which is the only one I do see when trying to run anything. Maybe that has to do with it?

As far as I know, I’ve made it through all steps in the guides up to the following:

  • If this is a new install, or you have upgraded DaisyExamples, DaisySP, or libDaisy:
    • Launch the command palette with Ctrl+P on Windows or ⌘+P on macOS
    • Type task build_all. This will build the libraries, and the current example.
    • This step only has to be done on a new install, or when the source code has been updated inside of one of the libraries

task build_all (and the others) simply do not appear in Terminal>Run Task

Anybody know the quick fix here? (Windows 10)

Hello Thomas!

What do you have open in your VS Code right now? I believe you need to have a Daisy project open in order to see task build_all to show up.

I suggest opening up the Blink example’s folder by clicking File > Open Folder, then navigating to ~/Desktop/DaisyExamples/seed/Blink. And see if it shows up now.

Current view of VS Code. Thanks for the reply.

Cool, thanks for showing the screenshot.

And I want to double check that you did the following:

  • Open the terminal tab in the bottom of your VS Code window if not visible (Terminal → New Terminal)
  • There should be a + button with a dropdown menu in the top right of the terminal window
  • In that dropdown select Select Default Profile, then choose Git Bash

What’s displayed in “Problems” by the way?

Hey, I had set it to git bash with the path
C:\Program Files\Git\bin\bash.exe

And here are the “problems”:

Thank you for showing the error messages.

It looks like this forum user had a similar error:

Please have a look at the solution that was presented in the reply and let me know if it works.
If there’s still an issue, let me know and I would be happy to bring this up to the team member with more Windows experience.

Hi, just wanted to update you on this thread. I had a mac laptop laying around and did a clean install… I ended up at the same point (DaisyExamples on my desktop, toolchain installer run and installed, new VS Code) where i hit command+p and no new tasks show up (again, only echo from tasks.json and some folders like cppbuild show up after typing “task”). On my windows machine, I had tried a new git bash install and that changed nothing as well.

WAIT, I got it working now. I honestly can’t tell you what had changed, but I have it working on windows. I wonder if the new git install had cleared up some issues and I had tried to build too soon.

Thanks for the help!

1 Like

I’m glad to hear that it’s working now!

In case anyone else has this issue, vscode will use the .vscode/tasks.json file at the root of the folder you open, so if you open the DaisyExamples folder, it will use the DaisyExamples/.vscode/tasks.json file, which does not contain an entry for “build_all”. Open the specific folder you want, for example, DaisyExamples/seed/Blink, and you will see the tasks.

2 Likes

Thank you so much! I had the exact same problem…

1 Like