Anyone else using Terrarium with Gen~ or PD? LED/JSON question

Hi all! Not sure how many are working with this setup, but I’m wondering if there’s a way to access LED’s on the Terrarium using PD or Max MSP Gen~ without a custom JSON? I’ve used the pd2dsy and Oopsy tools to flash patches successfully to Terrarium, but still can’t get to the LED’s… I’m guessing a custom JSON is the way to that, but I’ve never created one and hit some roadblocks when trying…

Using the pd2dsy tool, when I try to flash I get something like:

json.decoder.JSONDecodeError: Expecting property name enclosed in double quotes: line 111 column 3 (char 2136)

Tried tinkering with the JSON, but returned similar results:

json.decoder.JSONDecodeError: Expecting ',' delimiter: line 110 column 4 (char 2132)

On the Max/MSP Gen~ side of things, I ran into a similar error as user @fadedinstruments did in another post (browsed the bpatcher for my custom JSON, tried to flash, nothing)

Anyone else trying to figure this out, or have any suggestions?? Longer range goal is to work up my own boards (I know I’ll need my own JSON for that too), but for now I’d love to get the Terrarium working 100%.

Hey! It looks like you may have just run into some simple JSON syntax errors. It would help to post the JSON, but going by the error it looks like you have a property name enclosed in single quotes ' instead of double quotes ". JSON is pretty strict with its formatting, so if it’s not exactly right, it won’t successfully parse.

As for Oopsy, did you uncheck the quiet button on the Oopsy object to see what might be causing the problem? It should output any errors to the Max console.

1 Like

You’re spot on. Tinkering with the JSON syntax fixed it and now I’m up and running! Thank you!

1 Like