Any alternatives to STM32CubeProg?

I’m installing it on a Mac. The installer doesn’t even start up unless I run it from the commmand line like this:

jre/bin/java -jar SetupSTM32CubeProgrammer-2.7.0.exe

Then it attempts to copy the files into:


And fails:

cp [redacted]/…/…/…/jre: No such file or directory

I could probably get it to work, but, honestly, this software seems so badly written that I’m not sure it’s safe to run. Is there some other way of installing firmware?

Hi @skybrian! Sorry to hear you’re having a rough time getting it installed.

ST maintains the Arduino Integration for STM32 (and therefore daisy). So, adding an alternative is a bit out of the scope of the DaisyDuino project. That said, I believe they have an open PR for adding support, or switching over to dfu-util which is what we use in all of the c++ based integrations. I don’t know the timeline on that addition, though.

While the software installation is certainly more difficult than it should be, I haven’t seen anything in the few years of using it that make it feel “unsafe” in anyway.

However, I recall having a similar issue when installing it on mac OS. I believe I was able to get by the “block” by right-clicking and pressing “open” instead of double-clicking on the installer.
If you don’t have JRE (Java Runtime Environment) installed it may prompt you to install it.

Could you specify the version of mac OS that you’re running. That way we can try to recreate the installation issue you’re having and provide a workaround or fix.

Thanks in advance!

This is on macOS High Sierra (10.13.6). I don’t have a JRE installed so I ran the one that’s included in the zip file from the command line (as described above). The installer’s UI does launch, but during the install it shows the ‘cp’ error in a dialog box.

I’m using another microcontroller for now. I’ll look into it further when I get back to it.