Analog Input value is different (A0~A3)

I wonder why analog input values are different for each terminal.

I connected the 10k potentiometer from ADC1 to ADC4 respectively and the code was written as below.

As ADC1 can read value changes in the range of 0-65535, therefore there is no problem with electronic component connection, so I wonder why ADC1 and the rest of the values are output in different ranges.

emphasized text```arduino
#include “DaisyDuino.h”

DaisyHardware hw;
size_t num_channels;

float analog_value0;
float analog_value1;
float analog_value2;
float analog_value3;


void setup() {
float sample_rate;
// Initialize seed at 48kHz
num_channels = hw.num_channels;
sample_rate = DAISY.get_samplerate();

pinMode(A0, INPUT);
pinMode(A1, INPUT);
pinMode(A2, INPUT);
pinMode(A3, INPUT);

// Check value of pot


void loop() {
analogReadResolution(16); //Not a GPIO Num

analog_value0 = analogRead(A0); //0~65535
analog_value1 = analogRead(A1); //0~1485
analog_value2 = analogRead(A2);
analog_value3 = analogRead(A3);

Serial.print(" | “);
Serial.print(” | “);
Serial.print(” | ");
}Preformatted text

Connect AGND to DGND.

Note: resolution settings above 10 are quite noisy (at least on my breadboard). The default is 10, which returns values from 0 - 1023.

Thx for reply. I’ve tried, sadly problem not solved.

Interesting. I ran your code here, and connecting AGND to DGND stabilized the results with 10 bit resolution. Don’t expect good numbers at higher resolution.

If it doesn’t work for you, something is wrong in your setup, or (unlikely) the Seed is defective.

Obviously the range of output numbers has changed, but the rest of the terminals still can’t read the values normally.

I hope the board isn’t defective.

How, exactly, is the pot wired?

I think I’ve got your solution. The rails for power and ground are split in the middle, so you don’t really have AGND connected to DGND, and two of your pots aren’t connected to power or ground at all.
I just verified that on my breadboard, which looks just like that.

Four little jumpers should get it working.

Thank you so much for researching Brad Board!

Thank you very much for your kind information, but I tried connecting with you as you advised, and I tried connecting the two myself, but the problem is still not solved.

A0 is output in full range up to 1023, A1 is outputting only very small range values. A2 and A3 are not even responsive to changes in the pot. I think it’s better to use a multiplexer.

Your conclusion is incorrect. A multiplexer is NOT better, you still have an error, OR you have a defective Seed or breadboard.

Many users use 4 pots with Daisy seed, with no multiplexer.


Finally it worked!! Thank you so much!

If we were in the same country, I would have bought you a cup of coffee.

Thanks again tele_player!!

1 Like