This Daisy submodule problem will surprise you

(the title is just a clickbait)

I just got a Patch.init() and went through the steps in the manual. Before installing the toolchain I wanted to just see if the module’s working and if I can get it to do anything - I went to the web programmer and tried the “blink” example - since this is what the documentation told me to doo. The messages in the web programmer seem to be correct - there’s a number of bytes written and a “done” message.

But nothing blinks :frowning:

Upon closer inspection I see no led to do any blinking… so perhaps it’s not that strange.

So, questions:

  • am I assuming correctly that the Submodule lacks the user led?
  • am I looking in the wrong place or is the documentation not updated for the Submodule?
  • is there anything simple I can try to see if the module works? Any examples which should work out-of-the-box and map correctly to the Patch.init() hardware? Maybe some cool patches that are known to work / easy to install?

Ah, so the “patch_sm” platform is the correct choice for Patch.init() - and the examples work fine. So at least number three is solved :slight_smile:

Actually, I am surprised how little work (in terms of configuration / power management etc.) was necessary to get something useful (a looper!) on my new Patch.init(). I am impressed and anxious to try more :slight_smile:

I’m patiently waiting for part 2 - “10 Daisy secrets the embedded engineers don’t want you to know!”

1 Like