Get Started Faster! (A newer, simpler way to install the toolchain)

@Assaf Silly question: have you tried quitting and reopening terminal?
The path variable doesn’t update until you do so. That may be why oopsy can’t find the arm toolchain.

1 Like

What is strange is that brew is saying that gcc-arm-embedded is already installed, but then it can’t be found.

Can you try to run:
brew reinstall gcc-arm-embedded

and then afterwards try to invoke the command itself:
arm-none-eabi-gcc --version

This may at least confirm if the tool is installed or not.

There is also a related thread on github that some people have managed to resolve the progress on. Though as far as I know, others on the M1 mac (and BigSur) have been successful in getting it to work with the install.command.

Hope that’s helpful, let us know how it goes or if you need more assistance troubleshooting.

1 Like

Got it up and running thank you!
What fixed it for me was using git to clone - otherwise the install.sh of oopsy doesnt work - and the errors were not very obvious

Hey, took me time to answer but it did work! thanks for your help!

1 Like

Hey! Glad to hear it.