DaisyDuino no Audio

Hi everyone,
I am a new Patch.init() owner and wanted to start to develop my own daisy programs.
I followed the whole process of setting up the Arduino IDE (on Mac) etc. and managed to upload the first examples (Blink, …).
My problem is that while the upload works and the code in the main loop seems to be executed properly (CV, Gates, LED, …), there is no audio coming from the unit.

If I upload examples via chrome, the audio is working properly.

Any ideas how to fix this issue?
Thank you so much for your help.

Sorry to hear you’re having issues!

First and foremost: I’d make sure your libraries are up to date.

  • You can update DaisyDuino from Tools > Manage Libraries. The latest version is 1.6.0
  • You can check on STM32 MCU based boards via Tools > Board: Generic STM32... > Boards Manager. The latest version of that is 2.3.0.

Also: make sure you have the Patch Init selected as your board.

  • You should have Tools > Board: "Generic STM32H7 Series" selected.
  • You should also have Tools > Board part number: "Daisy Patch SM" selected.

In addition, make sure you always press Reset on the Patch SM after flashing an example.

Let me know if that helps! If not, we can keep working through some troubleshooting steps.

I one more time checked all the settings you pointed me to, but again … no audio.

I am on a new M1 macbook with the Arduino Version 1.8.19 installed.
Before I installed Arduino I already had installed Teensyduino, since these are the boards I usually program.

Is it possible that this might introduced the error?

Thank you for helping me with this, I am already excited about developing my own firmware for the patch.init()

Thanks for your bug report!
I’ve got a fix in review now, hopefully it’ll be ready soon.
I’ll ping back here when that’s done!

1 Like

@beat Should be fixed now as of version 1.6.1! Thanks again for the report!

1 Like

you are awesome!
now it works! the only issue I had was that arduino is not showing version 1.6.1 in the library manager yet, so I downloaded it from github and manually installed it.

I am looking forward to explore the platform and develop my own modules!

@ben_serge I downloaded Daisyduino 1.6.1 via git then manually added the library via sketch>Include Library> add .ZIP library. The Arduino>libraries folder shows a DaisyDuino folder and a DaisyDuino 1.6.1 folder. I removed the DaisyDuino folder and restarted the Arduino IDE. My library manager still says DaisyDuino 1.6.0 and the audio of my patch SM still doesn’t work. Any ideas what I am doing wrong? Also just an FYI when I opened the “library.properties” document in the DaisyDuino 1.6.1 folder it says:

EDIT! Problem solved(!!) It is very likely just my ignorance around using GitHub but here’s what went wrong for what it’s worth.
I went to the DaisyDuino releases page (Releases · electro-smith/DaisyDuino · GitHub) and then to release v1.6.1 (Release v1.6.1 Fix Patch SM Audio Bug · electro-smith/DaisyDuino · GitHub) where I then downloaded the v1.6.1 zip. The file it downloaded was called DaisyDuino v1.6.1. But when I looked at library.properties it was named 1.6.0 (as mentioned above).
So I went back to the DaisyDuino main page (GitHub - electro-smith/DaisyDuino: Arduino Support for the Daisy Audio Platform.)and downloaded the zip and this time the file I downloaded was called DaisyDuino-master which was indeed the correct v1.6.1. The audio now works…huzzah!